ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tim Thorpe (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-22220) Should be able to switch the extension version to which a stack version is linked
Date Mon, 16 Oct 2017 13:19:02 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-22220?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Tim Thorpe updated AMBARI-22220:
--------------------------------
    Resolution: Fixed
        Status: Resolved  (was: Patch Available)

> Should be able to switch the extension version to which a stack version is linked 
> ----------------------------------------------------------------------------------
>
>                 Key: AMBARI-22220
>                 URL: https://issues.apache.org/jira/browse/AMBARI-22220
>             Project: Ambari
>          Issue Type: Improvement
>          Components: ambari-server
>    Affects Versions: trunk, 2.5.0, 2.6.0
>            Reporter: Tim Thorpe
>            Assignee: Tim Thorpe
>             Fix For: trunk
>
>         Attachments: AMBARI-22220.patch
>
>
> Currently the only way to switch the extension version to which a stack version is linked
is to perform the following actions:
> * Stop the extension services
> * Reregister (delete) the extension services
> * Unlink the old extension version
> * Link the new extension version
> * Add the extension services back
> The REST API should allow us to do an update action on the extension link.  In this manner,
if we were running an upgrade from HDP 2.6.1 to 2.6.3 (or something similar) which both use
the HDP 2.6 stack version then we could perform the extension link switch as a manual step
during the upgrade process.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message