ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-22203) ZKFC start failed due to hadoop-hdfs-zkfc is not supported
Date Wed, 11 Oct 2017 12:30:00 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-22203?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Onischuk updated AMBARI-22203:
-------------------------------------
    Attachment: AMBARI-22203.patch

> ZKFC start failed due to hadoop-hdfs-zkfc is not supported
> ----------------------------------------------------------
>
>                 Key: AMBARI-22203
>                 URL: https://issues.apache.org/jira/browse/AMBARI-22203
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Andrew Onischuk
>            Assignee: Andrew Onischuk
>             Fix For: 2.6.0
>
>         Attachments: AMBARI-22203.patch
>
>
> 1\. HDP-2.4.3.0-227 is installed on Ambari-2.5.2.0 (with HA)  
> 2\. Ambari is upgraded to Ambari-2.6.0.0  
> 3\. Code tries to get version of zkfc from hdp-select to advertise it. However
> hdp-select 2.4.3.0 does not support zkfc package
>     
>     
>     [root@aonishuk-gc6402-1 yum.repos.d]# rpm -q hdp-select
>     hdp-select-2.4.3.0-227.el6.noarch
>     [root@aonishuk-gc6402-1 yum.repos.d]# hdp-select packages | grep zkfc
>     [root@aonishuk-gc6402-1 yum.repos.d]#
>     
> vs
>     
>     
>     [root@natr76-nbzs-dgtofnmlevelha-r7-1 ~]# rpm -q hdp-select
>     hdp-select-2.5.3.0-37.el6.noarch
>     [root@natr76-nbzs-dgtofnmlevelha-r7-1 ~]# hdp-select packages | grep zkfc
>       hadoop-hdfs-zkfc
>     
>     
>     
>     Traceback (most recent call last):
>       File "/var/lib/ambari-agent/cache/stacks/HDP/2.0.6/hooks/before-START/scripts/hook.py",
line 43, in <module>
>         BeforeStartHook().execute()
>       File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 374, in execute
>         self.save_component_version_to_structured_out(self.command_name)
>       File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 244, in save_component_version_to_structured_out
>         stack_select_package_name = stack_select.get_package_name()
>       File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/stack_select.py",
line 109, in get_package_name
>         package = get_packages(PACKAGE_SCOPE_STACK_SELECT, service_name, component_name)
>       File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/stack_select.py",
line 234, in get_packages
>         raise Fail("The package {0} is not supported by this version of the stack-select
tool.".format(package))
>     resource_management.core.exceptions.Fail: The package hadoop-hdfs-zkfc is not supported
by this version of the stack-select tool.
>     



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message