ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-22194) Prevent Patch Upgrades With Known Service Incompatibilities
Date Wed, 11 Oct 2017 14:15:00 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-22194?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16200342#comment-16200342
] 

Hudson commented on AMBARI-22194:
---------------------------------

FAILURE: Integrated in Jenkins build Ambari-trunk-Commit #8249 (See [https://builds.apache.org/job/Ambari-trunk-Commit/8249/])
AMBARI-22194 - Prevent Patch Upgrades With Known Service (jhurley: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=c19f363c877776623fd42d285717e6e95b9036ad])
* (edit) ambari-server/src/test/java/org/apache/ambari/server/state/CheckHelperTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/ComponentExistsInRepoCheckTest.java
* (edit) ambari-server/src/main/java/org/apache/ambari/server/controller/internal/ClusterStackVersionResourceProvider.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/RangerSSLConfigCheckTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/MapReduce2JobHistoryStatePreservingCheckTest.java
* (add) ambari-server/src/test/java/org/apache/ambari/server/checks/RequiredServicesInRepositoryCheckTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/KafkaKerberosCheckTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/ServicesNamenodeTruncateCheckTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/HiveNotRollingWarningTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/ServicesMapReduceDistributedCacheCheckTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/HiveMultipleMetastoreCheckTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/HostsHeartbeatCheckTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/ServicesNamenodeHighAvailabilityCheckTest.java
* (edit) ambari-server/src/main/java/org/apache/ambari/server/checks/CheckDescription.java
* (edit) ambari-server/src/main/resources/stacks/HDP/2.0.6/properties/stack_packages.json
* (edit) ambari-server/src/main/java/org/apache/ambari/server/state/RepositoryType.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/RangerAuditDbCheckTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/ComponentsInstallationCheckTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/AutoStartDisabledCheckTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/RangerPasswordCheckTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/ServicesTezDistributedCacheCheckTest.java
* (edit) ambari-server/src/main/java/org/apache/ambari/server/checks/AbstractCheckDescriptor.java
* (add) ambari-server/src/main/java/org/apache/ambari/server/state/repository/StackPackage.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/SecondaryNamenodeDeletedCheckTest.java
* (edit) ambari-server/src/main/java/org/apache/ambari/server/checks/UpgradeCheck.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/ServicesMaintenanceModeCheckTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/ClientRetryPropertyCheckTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/InstallPackagesCheckTest.java
* (add) ambari-server/src/main/java/org/apache/ambari/server/checks/RequiredServicesInRepositoryCheck.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/ConfigurationMergeCheckTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/ServicesYarnWorkPreservingCheckTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/DruidHighAvailabilityCheckTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/ServicesUpCheckTest.java
* (edit) ambari-server/src/main/java/org/apache/ambari/server/state/repository/VersionDefinitionXml.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/StormShutdownWarningTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/AbstractCheckDescriptorTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/HostsRepositoryVersionCheckTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/checks/HostsMasterMaintenanceCheckTest.java


> Prevent Patch Upgrades With Known Service Incompatibilities
> -----------------------------------------------------------
>
>                 Key: AMBARI-22194
>                 URL: https://issues.apache.org/jira/browse/AMBARI-22194
>             Project: Ambari
>          Issue Type: Bug
>    Affects Versions: 2.6.0
>            Reporter: Jonathan Hurley
>            Assignee: Jonathan Hurley
>            Priority: Blocker
>             Fix For: 2.6.0
>
>         Attachments: AMBARI-22194.patch
>
>
> Some stacks, such as HDP, do not support service-level upgrades for some services since
they have hard coded dependencies with other services which might not be in the upgrade. 
> For example, if YARN is configured to use Tez, then an upgrade of YARN or Tez must also
include Tez or YARN respectively. This is because the path is hard coded inside of YARN to
use its version and cannot be changed via any external environment variable.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message