ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Hurley (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-22194) Prevent Patch Upgrades With Known Service Incompatibilities
Date Tue, 10 Oct 2017 19:38:00 GMT
Jonathan Hurley created AMBARI-22194:
----------------------------------------

             Summary: Prevent Patch Upgrades With Known Service Incompatibilities
                 Key: AMBARI-22194
                 URL: https://issues.apache.org/jira/browse/AMBARI-22194
             Project: Ambari
          Issue Type: Bug
    Affects Versions: 2.6.0
            Reporter: Jonathan Hurley
            Assignee: Jonathan Hurley
            Priority: Blocker
             Fix For: 2.6.0


Some stacks, such as HDP, do not support service-level upgrades for some services since they
have hard coded dependencies with other services which might not be in the upgrade. 

For example, if YARN is configured to use Tez, then an upgrade of YARN or Tez must also include
Tez or YARN respectively. This is because the path is hard coded inside of YARN to use its
version and cannot be changed via any external environment variable.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message