ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dmytro Grinenko (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-22167) Ambari schema upgrade failed for Postgres DB with PSQLException for column "legacy"
Date Mon, 09 Oct 2017 13:43:00 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-22167?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16196976#comment-16196976
] 

Dmytro Grinenko commented on AMBARI-22167:
------------------------------------------

Committed:

2aa6e856c2..53b269989c  branch-2.6 -> branch-2.6

> Ambari schema upgrade failed for Postgres DB with PSQLException for column "legacy"
> -----------------------------------------------------------------------------------
>
>                 Key: AMBARI-22167
>                 URL: https://issues.apache.org/jira/browse/AMBARI-22167
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.6.0
>            Reporter: Dmytro Grinenko
>            Assignee: Dmytro Grinenko
>            Priority: Blocker
>             Fix For: 2.6.0
>
>
> On ambari upgrade with external PostgreSQL: 
> {code}
> 09 Oct 2017 01:27:43,091 ERROR [main] SchemaUpgradeHelper:202 - Upgrade failed.
> org.postgresql.util.PSQLException: ERROR: column "legacy" is of type boolean but default
expression is of type integer
>   Hint: You will need to rewrite or cast the expression.
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message