ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-22127) Package install fails on Debian7 with 'EMPTY_FILE' global variable not defined
Date Thu, 05 Oct 2017 15:01:14 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-22127?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16192978#comment-16192978
] 

Hudson commented on AMBARI-22127:
---------------------------------

SUCCESS: Integrated in Jenkins build Ambari-branch-2.6 #334 (See [https://builds.apache.org/job/Ambari-branch-2.6/334/])
AMBARI-22127. Installation of stack selector fails on Debian (adoroszlai: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=f1eaa6502ea53cd90f674cd87d3010d37ea4dc46])
* (edit) ambari-common/src/main/python/resource_management/core/providers/package/choco.py
* (edit) ambari-server/src/test/python/custom_actions/TestInstallPackages.py
* (edit) ambari-common/src/main/python/resource_management/libraries/functions/repository_util.py
* (edit) ambari-agent/src/test/python/resource_management/TestPackageResource.py
* (edit) ambari-common/src/main/python/resource_management/core/resources/packaging.py
* (edit) ambari-server/src/main/resources/custom_actions/scripts/install_packages.py
* (edit) ambari-common/src/main/python/resource_management/core/providers/package/yumrpm.py
* (edit) ambari-common/src/main/python/resource_management/core/providers/package/apt.py
* (edit) ambari-common/src/main/python/resource_management/core/providers/package/__init__.py
* (edit) ambari-common/src/main/python/resource_management/core/providers/package/zypper.py


> Package install fails on Debian7 with 'EMPTY_FILE' global variable not defined
> ------------------------------------------------------------------------------
>
>                 Key: AMBARI-22127
>                 URL: https://issues.apache.org/jira/browse/AMBARI-22127
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.6.0
>            Reporter: Vivek Sharma
>            Assignee: Doroszlai, Attila
>            Priority: Blocker
>              Labels: express_upgrade
>             Fix For: 2.6.0
>
>         Attachments: AMBARI-22127_branch-2.6.patch, AMBARI-22127_trunk.patch
>
>
> *STR*
> # Deployed cluster with Ambari version: 2.5.1.0-159 and HDP version: 2.5.6.0-40
> # Upgrade Ambari to 2.6.0.0-173
> # Register HDP Version 2.6.3.0-151 and try to install the packages
> *Result*
> Package install fails with below error
> {code}
> 2017-10-03 05:27:09,454 - Will install packages for repository version 2.6.3.0-151
> 2017-10-03 05:27:09,455 - Repository['HDP-2.6-repo-51'] {'append_to_file': False, 'base_url':
'http://s3.amazonaws.com/dev.hortonworks.com/HDP/debian7/2.x/BUILDS/2.6.3.0-151', 'action':
['create'], 'components': ['HDP', 'main'], 'repo_template': '{{package_type}} {{base_url}}
{{components}}', 'repo_file_name': 'ambari-hdp-51', 'mirror_list': None}
> 2017-10-03 05:27:09,460 - File['/tmp/tmpPriIC1'] {'content': 'deb http://s3.amazonaws.com/dev.hortonworks.com/HDP/debian7/2.x/BUILDS/2.6.3.0-151
HDP main'}
> 2017-10-03 05:27:09,461 - Writing File['/tmp/tmpPriIC1'] because contents don't match
> 2017-10-03 05:27:09,461 - File['/tmp/tmpWBU9KY'] {'content': StaticFile('/etc/apt/sources.list.d/ambari-hdp-51.list')}
> 2017-10-03 05:27:09,462 - Writing File['/tmp/tmpWBU9KY'] because contents don't match
> 2017-10-03 05:27:09,462 - File['/etc/apt/sources.list.d/ambari-hdp-51.list'] {'content':
StaticFile('/tmp/tmpPriIC1')}
> 2017-10-03 05:27:09,463 - Writing File['/etc/apt/sources.list.d/ambari-hdp-51.list']
because contents don't match
> 2017-10-03 05:27:09,463 - checked_call[['apt-get', 'update', '-qq', '-o', 'Dir::Etc::sourcelist=sources.list.d/ambari-hdp-51.list',
'-o', 'Dir::Etc::sourceparts=-', '-o', 'APT::Get::List-Cleanup=0']] {'sudo': True, 'quiet':
False}
> 2017-10-03 05:27:10,166 - checked_call returned (0, '')
> 2017-10-03 05:27:10,169 - Repository['HDP-UTILS-1.1.0.21-repo-51'] {'append_to_file':
True, 'base_url': 'http://s3.amazonaws.com/dev.hortonworks.com/HDP-UTILS-1.1.0.21/repos/debian7',
'action': ['create'], 'components': ['HDP-UTILS', 'main'], 'repo_template': '{{package_type}}
{{base_url}} {{components}}', 'repo_file_name': 'ambari-hdp-51', 'mirror_list': None}
> 2017-10-03 05:27:10,176 - File['/tmp/tmpnjTvFL'] {'content': 'deb http://s3.amazonaws.com/dev.hortonworks.com/HDP/debian7/2.x/BUILDS/2.6.3.0-151
HDP main\ndeb http://s3.amazonaws.com/dev.hortonworks.com/HDP-UTILS-1.1.0.21/repos/debian7
HDP-UTILS main'}
> 2017-10-03 05:27:10,176 - Writing File['/tmp/tmpnjTvFL'] because contents don't match
> 2017-10-03 05:27:10,177 - File['/tmp/tmprvUQz1'] {'content': StaticFile('/etc/apt/sources.list.d/ambari-hdp-51.list')}
> 2017-10-03 05:27:10,178 - Writing File['/tmp/tmprvUQz1'] because contents don't match
> 2017-10-03 05:27:10,179 - File['/etc/apt/sources.list.d/ambari-hdp-51.list'] {'content':
StaticFile('/tmp/tmpnjTvFL')}
> 2017-10-03 05:27:10,180 - Writing File['/etc/apt/sources.list.d/ambari-hdp-51.list']
because contents don't match
> 2017-10-03 05:27:10,181 - checked_call[['apt-get', 'update', '-qq', '-o', 'Dir::Etc::sourcelist=sources.list.d/ambari-hdp-51.list',
'-o', 'Dir::Etc::sourceparts=-', '-o', 'APT::Get::List-Cleanup=0']] {'sudo': True, 'quiet':
False}
> 2017-10-03 05:27:11,641 - checked_call returned (0, '')
> 2017-10-03 05:27:11,642 - call[('ambari-python-wrap', '/usr/bin/hdp-select', 'versions')]
{}
> 2017-10-03 05:27:11,681 - call returned (0, '2.5.6.0-40')
> 2017-10-03 05:27:11,683 - Package['hdp-select'] {'retry_on_repo_unavailability': True,
'retry_count': 5, 'use_repos': ['HDP-2.6-repo-51', 'HDP-UTILS-1.1.0.21-repo-51'], 'action':
['upgrade']}
> 2017-10-03 05:27:11,683 - Temporal sources directory was created: /tmp/tmpN_6yuF-ambari-apt-sources-d
> 2017-10-03 05:27:11,683 - Package Manager failed to install packages. Error: global name
'EMPTY_FILE' is not defined
> Traceback (most recent call last):
>   File "/var/lib/ambari-agent/cache/custom_actions/scripts/install_packages.py", line
335, in install_packages
>     retry_count=agent_stack_retry_count)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 166,
in __init__
>     self.env.run()
>   File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line
160, in run
>     self.run_action(resource, action)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line
124, in run_action
>     provider_action()
>   File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/__init__.py",
line 57, in action_upgrade
>     self.upgrade_package(package_name, self.resource.use_repos, self.resource.skip_repos)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/apt.py",
line 74, in wrapper
>     return function_to_decorate(self, name, *args[2:])
>   File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/apt.py",
line 385, in upgrade_package
>     return self.install_package(name, use_repos, skip_repos, is_upgrade)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/apt.py",
line 74, in wrapper
>     return function_to_decorate(self, name, *args[2:])
>   File "/usr/lib/python2.6/site-packages/resource_management/core/providers/package/apt.py",
line 352, in install_package
>     cmd = cmd + ['-o', 'Dir::Etc::SourceList=%s' % EMPTY_FILE]
> NameError: global name 'EMPTY_FILE' is not defined
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message