ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Hurley (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-22076) Use A Scoped Repo When Installing stack-tools
Date Wed, 27 Sep 2017 16:12:00 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-22076?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jonathan Hurley updated AMBARI-22076:
-------------------------------------
    Status: Patch Available  (was: Open)

> Use A Scoped Repo When Installing stack-tools
> ---------------------------------------------
>
>                 Key: AMBARI-22076
>                 URL: https://issues.apache.org/jira/browse/AMBARI-22076
>             Project: Ambari
>          Issue Type: Bug
>    Affects Versions: 2.6.0
>            Reporter: Jonathan Hurley
>            Assignee: Jonathan Hurley
>            Priority: Blocker
>             Fix For: 2.6.0
>
>         Attachments: AMBARI-22076.patch
>
>
> Ambari does not write out repositories with a "priority" attribute since this is a plugin
and is not guaranteed to be installed. Also, when installing packages with versions "in the
middle" of two other installed stacks, priority would be incorrect as the most recent stack-tools
should always be used.
> The following is seen when trying to distribute a stack for a patch upgrade:
> {code}
> 2017-09-26 16:28:58,652 - Package Manager failed to install packages. Error: Execution
of '/usr/bin/yum -d 0 -e 0 -y install hive_2_6_3_1_1' returned 1. Error: Package: hadoop_2_6_3_1_1-2.7.3.2.6.3.1-1.x86_64
(HDP-2.6-repo-2)
>            Requires: hdp-select >= 2.6.3.1-1
>            Installed: hdp-select-2.6.3.0-122.noarch (@HDP-2.6.3.0-122)
>                hdp-select = 2.6.3.0-122
> {code}
> The cause of this seems to be that the repository for HDP-2.6-repo-2 does not take priority
over the existing installed repository for {{hdp-select}}. That's actually good - it shouldn't
take priority over it arbitrarily. 
> However, this means that the {{hdp-select}} which is installed did not get taken from
{{HDP-2.6-repo-2}}. So, when installing {{hdp-select}}, we should scope the install to the
repo we are trying to calculate the version for.
> This works because the stack-select tools do not have their package names versioned ({{hdp-select}}
as opposed to {{hdp-select_x_y_z}}.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message