ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Myroslav Papirkovskyi (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-22029) Download Client Configs fails
Date Mon, 25 Sep 2017 16:10:00 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-22029?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Myroslav Papirkovskyi updated AMBARI-22029:
-------------------------------------------
    Summary: Download Client Configs fails  (was: "Download All Client Configs" for a cluster
and downloading clients from a host with Oozie client fails)

> Download Client Configs fails
> -----------------------------
>
>                 Key: AMBARI-22029
>                 URL: https://issues.apache.org/jira/browse/AMBARI-22029
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.6.0
>            Reporter: Myroslav Papirkovskyi
>            Assignee: Myroslav Papirkovskyi
>            Priority: Blocker
>             Fix For: 2.6.0
>
>
> * Navigate to Dashboard page and use Download All Client Configs to download all client
configs for the cluster. It fails
> * Go to host with Oozie client and from Host Actions - Download Client Configs - All
Clients on Host. This action also fails
> * Download just Oozie client from the host. That one fails too
> {code}
> {
> status: 500,
> message: "org.apache.ambari.server.controller.spi.SystemException: Execution of "ambari-python-wrap
/var/lib/ambari-server/resources/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_client.py
generate_configs /var/lib/ambari-server/data/tmp/OOZIE_CLIENT8027664465495831823-configuration.json
/var/lib/ambari-server/resources/common-services/OOZIE/4.0.0.2.0/package /var/lib/ambari-server/data/tmp/structured-out.json
INFO /var/lib/ambari-server/data/tmp" returned 1. java.lang.Throwable: 2017-09-19 21:23:43,446
- Stack Feature Version Info: Cluster Stack=2.6, Command Stack=None, Command Version=None
-> 2.6
> 2017-09-19 21:23:43,447 - Using hadoop conf dir: /usr/hdp/current/hadoop-client/conf
> Traceback (most recent call last):
>   File "/var/lib/ambari-server/resources/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie_client.py",
line 71, in <module>
>     OozieClient().execute()
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 327, in execute
>     method(env)
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 964, in generate_configs
>     import params
>   File "/var/lib/ambari-server/resources/common-services/OOZIE/4.0.0.2.0/package/scripts/params.py",
line 28, in <module>
>     from params_linux import *
>   File "/var/lib/ambari-server/resources/common-services/OOZIE/4.0.0.2.0/package/scripts/params_linux.py",
line 387, in <module>
>     all_lzo_packages = get_lzo_packages(stack_version_unformatted)
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/get_lzo_packages.py",
line 45, in get_lzo_packages
>     lzo_packages += [script_instance.format_package_name("hadooplzo_${stack_version}"),
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 476, in format_package_name
>     repo_version = self.get_stack_version_before_packages_installed()
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 430, in get_stack_version_before_packages_installed
>     stack_select_package_name = stack_select.get_package_name()
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/functions/stack_select.py",
line 100, in get_package_name
>     raise Fail("Both the role and the service name must be included in the command in
order to determine which packages to use with the stack-select tool")
> resource_management.core.exceptions.Fail: Both the role and the service name must be
included in the command in order to determine which packages to use with the stack-select
tool
> "
> }
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message