ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Levas (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-21997) Unsupported major.minor version 52.0 when using com.networknt:json-schema-validator
Date Tue, 19 Sep 2017 15:51:00 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-21997?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Levas updated AMBARI-21997:
----------------------------------
    Attachment: AMBARI-21997_branch-2.6_01.patch
                AMBARI-21997_trunk_01.patch

> Unsupported major.minor version 52.0 when using com.networknt:json-schema-validator
> -----------------------------------------------------------------------------------
>
>                 Key: AMBARI-21997
>                 URL: https://issues.apache.org/jira/browse/AMBARI-21997
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.6.0
>            Reporter: Robert Levas
>            Assignee: Robert Levas
>            Priority: Critical
>             Fix For: 2.6.0
>
>         Attachments: AMBARI-21997_branch-2.6_01.patch, AMBARI-21997_trunk_01.patch
>
>
> {code}
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.20:test
(default-test) on project ambari-server: Execution default-test of goal org.apache.maven.plugins:maven-surefire-plugin:2.20:test
failed: java.lang.UnsupportedClassVersionError: com/networknt/schema/JsonSchema : Unsupported
major.minor version 52.0 -> [Help 1]
> {code}
> *Cause*
> com.networknt:json-schema-validator:0.1.7 is compiled for Java 1.8, causing unit tests
to fail when using Java 1.7
> *Solution*
> Use com.networknt:json-schema-validator:0.1.10, which appears to work when using either
Java 1.7 or Java 1.8.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message