ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-21940) Ambari schema upgrade from any version older than 2.5.1 fails due to incorrect version check
Date Thu, 14 Sep 2017 17:08:00 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-21940?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16166610#comment-16166610
] 

Hudson commented on AMBARI-21940:
---------------------------------

FAILURE: Integrated in Jenkins build Ambari-branch-2.6 #212 (See [https://builds.apache.org/job/Ambari-branch-2.6/212/])
AMBARI-21940. Ambari schema upgrade from any version older than 2.5.1 (dlysnichenko: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=6407f9329ed6ece32ba64d92205f164eb2b8732d])
* (add) ambari-server/src/test/java/org/apache/ambari/server/upgrade/UpgradeCatalog242Test.java
* (add) ambari-server/src/main/java/org/apache/ambari/server/upgrade/UpgradeCatalog2402.java
* (add) ambari-server/src/main/java/org/apache/ambari/server/upgrade/UpgradeCatalog242.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/upgrade/SchemaUpgradeHelperTest.java
* (add) ambari-server/src/test/java/org/apache/ambari/server/upgrade/UpgradeCatalog250Test.java
* (edit) ambari-server/src/main/java/org/apache/ambari/server/upgrade/SchemaUpgradeHelper.java
* (add) ambari-server/src/main/java/org/apache/ambari/server/upgrade/UpgradeCatalog250.java


> Ambari schema upgrade from any version older than 2.5.1 fails due to incorrect version
check 
> ---------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-21940
>                 URL: https://issues.apache.org/jira/browse/AMBARI-21940
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.6.0
>            Reporter: Vivek Sharma
>            Assignee: Dmitry Lysnichenko
>            Priority: Blocker
>              Labels: upgrade
>             Fix For: 2.6.0
>
>         Attachments: AMBARI-21940.patch, AMBARI-21940.patch
>
>
> Perform an upgrade from Ambari version older than 2.5.1 (like 2.5.0 or 2.4.x) to 2.6.0
> Fails with below error
> {code}
> 12 Sep 2017 02:16:35,727  INFO [main] TransactionalLock$LockArea:121 - LockArea HRC_STATUS_CACHE
is enabled
> 12 Sep 2017 02:16:36,091  INFO [main] LockFactory:53 - Lock profiling is disabled
> 12 Sep 2017 02:16:36,112  INFO [main] SchemaUpgradeHelper:391 - Upgrading schema to target
version = 2.6.0.0
> 12 Sep 2017 02:16:36,115  INFO [main] SchemaUpgradeHelper:400 - Upgrading schema from
source version = 2.5.0
> 12 Sep 2017 02:16:36,118 ERROR [main] SchemaUpgradeHelper:434 - Exception occurred during
upgrade, failed
> org.apache.ambari.server.AmbariException: Database version does not meet minimal upgrade
requirements. Expected version should be not less than 2.5.1, current version is 2.5.0
>         at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.main(SchemaUpgradeHelper.java:405)
> 12 Sep 2017 02:16:40,419  INFO [main] Configuration:3044 - Reading password from existing
file
> 12 Sep 2017 02:16:40,439  INFO [main] Configuration:3529 - Hosts Mapping File null
> 12 Sep 2017 02:16:40,439  INFO [main] HostsMap:60 - Using hostsmap file null
> 12 Sep 2017 02:16:41,290  INFO [main] ControllerModule:221 - Detected MYSQL as the database
type from the JDBC URL
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message