ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sebastian Toader (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-21882) Throw an error if unsupported database JDBC driver is configured for HDP services
Date Tue, 05 Sep 2017 16:14:00 GMT
Sebastian Toader created AMBARI-21882:
-----------------------------------------

             Summary: Throw an error if unsupported database JDBC driver is configured for
HDP services
                 Key: AMBARI-21882
                 URL: https://issues.apache.org/jira/browse/AMBARI-21882
             Project: Ambari
          Issue Type: Task
          Components: ambari-server
            Reporter: Sebastian Toader
            Assignee: Sebastian Toader
             Fix For: 2.6.0


Ambari supports a couple of RDBMSes which can be set up via {{ambari-server setup}} in order
to have JDBC drivers available for agents. Agent will download the JDBC driver from the server
for HDP services that needs access to a RDBMS. 

The start scripts of these HDP service component checks the service configuration for the
type of JDBC driver and will use the appropriate JDBC driver.

In case the service configuration refers to a JDBC driver type that is not supported by Ambari
the start script should fail with an error that explicitly informs the user that an unsupported
JDBC driver type has been specified.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message