ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Hurley (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-21782) Service Accounts page shows no data for stack services after Ambari is upgraded on IOP cluster
Date Tue, 22 Aug 2017 18:56:02 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-21782?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16137191#comment-16137191
] 

Jonathan Hurley commented on AMBARI-21782:
------------------------------------------

It looks like the cause here is that Ambari looks for both the {{USER}} property type _and_
the {{user}} property attribute for some reason. That's just odd ...

{code}
  "StackConfigurations": {
    "final": "false",
    "property_depends_on": [],
    "property_description": "ZooKeeper User.",
    "property_name": "zk_user",
    "property_type": [
      "USER"
    ],
    "property_value": "zookeeper",
    "property_value_attributes": {
      "keyStore": false
    },
    "service_name": "ZOOKEEPER",
    "stack_name": "BigInsights",
    "stack_version": "4.2",
    "type": "zookeeper-env.xml"
  },
  "dependencies": []
{code}

> Service Accounts page shows no data for stack services after Ambari is upgraded on IOP
cluster
> ----------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-21782
>                 URL: https://issues.apache.org/jira/browse/AMBARI-21782
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-web
>    Affects Versions: 2.5.2
>            Reporter: Vivek Sharma
>            Assignee: Jonathan Hurley
>            Priority: Critical
>             Fix For: 2.6.0
>
>
> *STR*
> # Install BI-4.2.0 with Ambari-2.2.0 (all services are installed)
> # Upgrade Ambari to 2.5.2.0-274
> # Go to Service Accounts page
> *Result:*
> No entry is present for any of the stack services. The only entry is for AMS
> This appears a UI issue where we are unable to get the list of services and their user
accounts if their stack is still BI
> *Note*: After the cluster is Express Upgraded from BI-4.2.0 to HDP-2.6.2, the entries
in Service Accounts page show up fine



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message