ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-21734) Upgrade Associated Repository is Wrong for Downgrades and Patches
Date Thu, 17 Aug 2017 19:42:00 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-21734?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16131189#comment-16131189
] 

Hudson commented on AMBARI-21734:
---------------------------------

FAILURE: Integrated in Jenkins build Ambari-branch-2.6 #24 (See [https://builds.apache.org/job/Ambari-branch-2.6/24/])
AMBARI-21734 - Upgrade Associated Repository is Wrong for Downgrades and (jhurley: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=ba15d80e26b05468ec241470cf38b8530146460d])
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HIVE/package/scripts/hive_metastore.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KAFKA/package/scripts/kafka_broker.py
* (edit) ambari-server/src/main/resources/stacks/HDP/2.0.6/properties/stack_features.json
* (edit) ambari-common/src/main/python/resource_management/libraries/functions/upgrade_summary.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KAFKA/package/scripts/upgrade.py
* (edit) ambari-server/src/main/resources/common-services/HIVE/0.12.0.2.0/package/scripts/hive_metastore.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HIVE/package/scripts/params_linux.py
* (edit) ambari-server/src/main/java/org/apache/ambari/server/state/UpgradeContext.java
* (edit) contrib/management-packs/odpi-ambari-mpack/src/main/resources/stacks/ODPi/2.0/services/HIVE/package/scripts/hive_server_upgrade.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.0/properties/stack_features.json
* (edit) ambari-server/src/main/resources/common-services/HIVE/0.12.0.2.0/package/scripts/hive_server_upgrade.py
* (edit) ambari-server/src/main/resources/common-services/KAFKA/0.8.1/package/scripts/kafka.py
* (edit) ambari-server/src/test/python/stacks/2.1/HIVE/test_hive_metastore.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2/services/KAFKA/package/scripts/kafka_broker.py
* (edit) ambari-server/src/main/resources/common-services/KAFKA/0.8.1/package/scripts/upgrade.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/hive_server_upgrade.py
* (edit) ambari-server/src/test/python/TestUpgradeSummary.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/hive_metastore.py
* (edit) ambari-server/src/main/java/org/apache/ambari/server/controller/internal/UpgradeResourceProvider.java
* (edit) ambari-server/src/main/resources/common-services/KAFKA/0.8.1/package/scripts/kafka_broker.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KAFKA/package/scripts/params.py
* (edit) contrib/management-packs/odpi-ambari-mpack/src/main/resources/stacks/ODPi/2.0/services/HIVE/package/scripts/params_linux.py
* (edit) ambari-server/src/test/java/org/apache/ambari/server/state/UpgradeContextTest.java
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HIVE/package/scripts/hive_server_upgrade.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/params.py
* (edit) ambari-common/src/main/python/resource_management/libraries/functions/constants.py
* (edit) ambari-server/src/main/java/org/apache/ambari/server/orm/entities/UpgradeHistoryEntity.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/controller/internal/UpgradeResourceProviderTest.java
* (edit) ambari-server/src/main/resources/common-services/HIVE/0.12.0.2.0/package/scripts/params_linux.py
* (edit) ambari-server/src/main/resources/common-services/KAFKA/0.8.1/package/scripts/params.py
* (edit) contrib/management-packs/odpi-ambari-mpack/src/main/resources/stacks/ODPi/2.0/services/HIVE/package/scripts/hive_metastore.py


> Upgrade Associated Repository is Wrong for Downgrades and Patches
> -----------------------------------------------------------------
>
>                 Key: AMBARI-21734
>                 URL: https://issues.apache.org/jira/browse/AMBARI-21734
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.6.0
>            Reporter: Jonathan Hurley
>            Assignee: Jonathan Hurley
>            Priority: Critical
>             Fix For: 2.6.0
>
>         Attachments: AMBARI-21734.patch
>
>
> During a patch reversion, the associated repository of the upgrade was the target. This
seems wrong as the associated version on a downgrade is the single repo that you're coming
from. 
> When this was changed, it caused problems setting the desired repository, so something
is definitely wrong here. 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message