ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-21722) Begin Using Service Versions In Python stack_feature Code
Date Thu, 17 Aug 2017 19:42:00 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-21722?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16131185#comment-16131185
] 

Hudson commented on AMBARI-21722:
---------------------------------

FAILURE: Integrated in Jenkins build Ambari-branch-2.6 #24 (See [https://builds.apache.org/job/Ambari-branch-2.6/24/])
AMBARI-21722 - Begin Using Service Versions In Python stack_feature Code (jhurley: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=e7f413d321e7c74463a6c1e5898b5739bef8f82f])
* (edit) ambari-server/src/test/python/stacks/2.0.6/configs/nn_eu.json
* (edit) ambari-server/src/main/java/org/apache/ambari/server/state/UpgradeContext.java
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2.5/hooks/after-INSTALL/scripts/params.py
* (edit) contrib/management-packs/odpi-ambari-mpack/src/main/resources/stacks/ODPi/2.0/services/HIVE/package/scripts/hive_server_upgrade.py
* (edit) ambari-server/src/test/python/stacks/2.3/configs/storm_default_secure.json
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SOLR/package/scripts/solr_upgrade.py
* (edit) ambari-server/src/test/java/org/apache/ambari/server/StateRecoveryManagerTest.java
* (edit) contrib/management-packs/odpi-ambari-mpack/src/main/resources/stacks/ODPi/2.0/services/HIVE/package/scripts/hive_metastore.py
* (edit) ambari-server/src/test/python/stacks/utils/RMFTestCase.py
* (edit) ambari-server/src/test/python/stacks/2.5/configs/ranger-kms-secured.json
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HIVE/package/scripts/hive_server_upgrade.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.0/services/ZOOKEEPER/package/scripts/params.py
* (edit) ambari-server/src/test/python/stacks/2.2/KNOX/test_knox_gateway.py
* (edit) ambari-server/src/main/resources/common-services/ZOOKEEPER/3.4.5/package/scripts/params_linux.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KAFKA/package/scripts/upgrade.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SOLR/package/scripts/params.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2/services/RANGER/package/scripts/params.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2/services/ZOOKEEPER/package/scripts/zookeeper_service.py
* (edit) contrib/management-packs/odpi-ambari-mpack/src/main/resources/stacks/ODPi/2.0/hooks/after-INSTALL/scripts/hook.py
* (edit) contrib/management-packs/odpi-ambari-mpack/src/main/resources/stacks/ODPi/2.0/services/HIVE/package/scripts/hive_service.py
* (edit) ambari-server/src/test/python/stacks/2.1/FALCON/test_service_check.py
* (edit) ambari-server/src/main/java/org/apache/ambari/server/agent/ExecutionCommand.java
* (edit) ambari-server/src/main/resources/common-services/KAFKA/0.8.1/package/scripts/params.py
* (edit) ambari-server/src/test/python/stacks/2.2/configs/knox_upgrade.json
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2.5/services/SOLR/package/scripts/params.py
* (edit) ambari-common/src/main/python/resource_management/libraries/functions/copy_tarball.py
* (edit) contrib/management-packs/odpi-ambari-mpack/src/main/resources/stacks/ODPi/2.0/services/HIVE/package/scripts/params_linux.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HIVE/package/scripts/hive_metastore.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2/services/KNOX/package/scripts/params.py
* (add) ambari-common/src/main/python/resource_management/libraries/functions/component_version.py
* (edit) ambari-server/src/main/java/org/apache/ambari/server/actionmanager/ExecutionCommandWrapper.java
* (edit) ambari-server/src/main/resources/common-services/HIVE/0.12.0.2.0/package/scripts/hive_service.py
* (edit) ambari-server/src/main/resources/common-services/KAFKA/0.8.1/package/scripts/kafka.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/hive_server_upgrade.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/hive_metastore.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.0/services/ZOOKEEPER/package/scripts/zookeeper_service.py
* (edit) ambari-server/src/main/java/org/apache/ambari/server/controller/AmbariManagementControllerImpl.java
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HIVE/package/scripts/params_linux.py
* (edit) ambari-server/src/test/python/stacks/2.1/HIVE/test_hive_metastore.py
* (edit) ambari-server/src/main/resources/common-services/HIVE/0.12.0.2.0/package/scripts/hive_server_upgrade.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KAFKA/package/scripts/kafka_broker.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.0/services/KAFKA/package/scripts/params.py
* (edit) ambari-server/src/test/python/stacks/2.5/configs/ranger-kms-default.json
* (edit) ambari-server/src/test/python/stacks/2.1/configs/hive-metastore-upgrade.json
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2/services/ZOOKEEPER/package/scripts/zookeeper.py
* (edit) ambari-server/src/test/python/stacks/2.0.6/HIVE/test_hive_server.py
* (edit) ambari-server/src/main/resources/common-services/HIVE/0.12.0.2.0/package/scripts/params_linux.py
* (add) ambari-server/src/test/python/TestUpgradeSummary.py
* (edit) ambari-server/src/test/python/stacks/2.1/FALCON/test_falcon_client.py
* (add) ambari-common/src/main/python/resource_management/libraries/functions/upgrade_summary.py
* (edit) ambari-server/src/test/python/stacks/2.0.6/hooks/after-INSTALL/test_after_install.py
* (edit) ambari-server/src/test/python/TestStackFeature.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2/services/KAFKA/package/scripts/params.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2/services/SOLR/package/scripts/params.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2/services/ZOOKEEPER/package/scripts/params.py
* (edit) contrib/management-packs/odpi-ambari-mpack/src/main/resources/stacks/ODPi/2.0/hooks/after-INSTALL/scripts/shared_initialization.py
* (edit) ambari-common/src/main/python/resource_management/libraries/functions/stack_features.py
* (edit) ambari-server/src/main/resources/common-services/FALCON/0.5.0.2.1/package/scripts/falcon.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2/services/SOLR/package/scripts/solr_upgrade.py
* (edit) ambari-server/src/main/resources/common-services/HIVE/0.12.0.2.0/package/scripts/hive_metastore.py
* (edit) ambari-server/src/test/python/stacks/2.0.6/HIVE/test_hive_service_check.py
* (edit) ambari-server/src/test/python/stacks/2.5/configs/ranger-admin-default.json
* (edit) ambari-server/src/test/python/stacks/2.6/configs/ranger-admin-secured.json
* (edit) ambari-server/src/main/resources/common-services/KNOX/0.5.0.2.2/package/scripts/params_linux.py
* (add) ambari-server/src/test/python/TestComponentVersionMapping.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2/services/SPARK/package/scripts/params.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.0/services/HIVE/package/scripts/params.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2/services/HBASE/package/scripts/params.py
* (edit) contrib/management-packs/odpi-ambari-mpack/src/main/resources/stacks/ODPi/2.0/hooks/after-INSTALL/scripts/params.py
* (edit) ambari-server/src/test/python/stacks/2.0.6/configs/secured.json
* (edit) ambari-server/src/main/resources/common-services/KAFKA/0.8.1/package/scripts/kafka_broker.py
* (edit) ambari-server/src/main/resources/common-services/OOZIE/4.0.0.2.0/package/scripts/oozie.py
* (edit) ambari-server/src/test/python/stacks/2.5/configs/ranger-admin-secured.json
* (edit) ambari-server/src/test/python/stacks/2.0.6/configs/nn_eu_standby.json
* (edit) ambari-server/src/test/python/stacks/2.3/configs/storm_default.json
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.0/services/SOLR/package/scripts/solr_service.py
* (edit) ambari-server/src/main/resources/common-services/RANGER/0.4.0/package/scripts/params.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2/services/KAFKA/package/scripts/kafka_broker.py
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.2/services/KAFKA/package/scripts/upgrade.py
* (edit) ambari-server/src/test/python/stacks/2.1/FALCON/test_falcon_server.py
* (edit) ambari-server/src/main/resources/common-services/KAFKA/0.8.1/package/scripts/upgrade.py
* (edit) ambari-server/src/main/resources/common-services/FALCON/0.5.0.2.1/package/scripts/params_linux.py
* (edit) ambari-server/src/test/python/stacks/2.6/configs/ranger-admin-default.json
* (edit) ambari-server/src/main/resources/stacks/BigInsights/4.0/services/ZOOKEEPER/package/scripts/zookeeper.py
* (edit) ambari-server/src/test/java/org/apache/ambari/server/utils/StageUtilsTest.java


> Begin Using Service Versions In Python stack_feature Code
> ---------------------------------------------------------
>
>                 Key: AMBARI-21722
>                 URL: https://issues.apache.org/jira/browse/AMBARI-21722
>             Project: Ambari
>          Issue Type: Task
>          Components: ambari-server
>    Affects Versions: 2.6.0
>            Reporter: Jonathan Hurley
>            Assignee: Jonathan Hurley
>            Priority: Critical
>             Fix For: 2.6.0
>
>         Attachments: AMBARI-21722.patch
>
>
> The command generators in Ambari are sending down the {{KeyName.CURRENT_VERSION}} ({{current_version}})
property in the JSON to the agents. This is being used to determine the "current cluster version"
which doesn't really exist anymore:
> {code:title=stack_features.py}
>   # something like 2.4.0.0-1234
>   # (or None if this is a cluster install and it hasn't been calculated yet)
>   current_cluster_version = default("/hostLevelParams/current_version", None)
> {code}
> This really needs to be calculated from the service's repository version instead.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message