ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Hurley (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-21722) Begin Using Service Versions In Python stack_feature Code
Date Tue, 15 Aug 2017 21:01:00 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-21722?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jonathan Hurley updated AMBARI-21722:
-------------------------------------
    Attachment: AMBARI-21722.patch

> Begin Using Service Versions In Python stack_feature Code
> ---------------------------------------------------------
>
>                 Key: AMBARI-21722
>                 URL: https://issues.apache.org/jira/browse/AMBARI-21722
>             Project: Ambari
>          Issue Type: Task
>          Components: ambari-server
>    Affects Versions: 2.6.0
>            Reporter: Jonathan Hurley
>            Assignee: Jonathan Hurley
>            Priority: Critical
>             Fix For: 2.6.0
>
>         Attachments: AMBARI-21722.patch
>
>
> The command generators in Ambari are sending down the {{KeyName.CURRENT_VERSION}} ({{current_version}})
property in the JSON to the agents. This is being used to determine the "current cluster version"
which doesn't really exist anymore:
> {code:title=stack_features.py}
>   # something like 2.4.0.0-1234
>   # (or None if this is a cluster install and it hasn't been calculated yet)
>   current_cluster_version = default("/hostLevelParams/current_version", None)
> {code}
> This really needs to be calculated from the service's repository version instead.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message