ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Hurley (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-21642) Add hadoop LZO jars if installed in the cluster
Date Wed, 09 Aug 2017 17:31:00 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-21642?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16120314#comment-16120314
] 

Jonathan Hurley commented on AMBARI-21642:
------------------------------------------

[~swapanshridhar] This commit causes build failures in trunk. We should revert this until
they are fixed.

{code}
ERROR: test_stop_overlord (test_druid.TestDruid)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/jhurley/src/apache/ambari/ambari-common/src/test/python/mock/mock.py", line
1199, in patched
    return func(*args, **keywargs)
  File "/Users/jhurley/src/apache/ambari/ambari-server/src/test/python/stacks/2.6/DRUID/test_druid.py",
line 83, in test_stop_overlord
    target=RMFTestCase.TARGET_COMMON_SERVICES
  File "/Users/jhurley/src/apache/ambari/ambari-server/src/test/python/stacks/utils/RMFTestCase.py",
line 162, in executeScript
    method(RMFTestCase.env, *command_args)
  File "/Users/jhurley/src/apache/ambari/ambari-server/src/main/resources/common-services/DRUID/0.9.2/package/scripts/druid_node.py",
line 90, in stop
    import params
  File "/Users/jhurley/src/apache/ambari/ambari-server/src/main/resources/common-services/DRUID/0.9.2/package/scripts/params.py",
line 244, in <module>
    lzo_packages = get_lzo_packages(stack_version_unformatted)
  File "/Users/jhurley/src/apache/ambari/ambari-common/src/main/python/resource_management/libraries/functions/get_lzo_packages.py",
line 45, in get_lzo_packages
    lzo_packages += [script_instance.format_package_name("hadooplzo_${stack_version}"),
  File "/Users/jhurley/src/apache/ambari/ambari-common/src/main/python/resource_management/libraries/script/script.py",
line 520, in format_package_name
    stack_version_package_formatted = self.get_stack_version_before_packages_installed().replace('.',
package_delimiter).replace('-', package_delimiter) if STACK_VERSION_PLACEHOLDER in name else
name
  File "/Users/jhurley/src/apache/ambari/ambari-common/src/main/python/resource_management/libraries/script/script.py",
line 459, in get_stack_version_before_packages_installed
    stack_tools.get_stack_tool_package(stack_tools.STACK_SELECTOR_NAME))
  File "/Users/jhurley/src/apache/ambari/ambari-common/src/main/python/resource_management/libraries/functions/packages_analyzer.py",
line 319, in getInstalledPackageVersion
    code, out, err = rmf_shell.checked_call("rpm -q --queryformat '%{{version}}-%{{release}}'
{0} | sed -e 's/\.el[0-9]//g'".format(package_name), stderr=subprocess.PIPE)
ValueError: need more than 2 values to unpack

ERROR: test_stop_router (test_druid.TestDruid)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/Users/jhurley/src/apache/ambari/ambari-common/src/test/python/mock/mock.py", line
1199, in patched
    return func(*args, **keywargs)
  File "/Users/jhurley/src/apache/ambari/ambari-server/src/test/python/stacks/2.6/DRUID/test_druid.py",
line 221, in test_stop_router
    target=RMFTestCase.TARGET_COMMON_SERVICES
  File "/Users/jhurley/src/apache/ambari/ambari-server/src/test/python/stacks/utils/RMFTestCase.py",
line 162, in executeScript
    method(RMFTestCase.env, *command_args)
  File "/Users/jhurley/src/apache/ambari/ambari-server/src/main/resources/common-services/DRUID/0.9.2/package/scripts/druid_node.py",
line 90, in stop
    import params
  File "/Users/jhurley/src/apache/ambari/ambari-server/src/main/resources/common-services/DRUID/0.9.2/package/scripts/params.py",
line 244, in <module>
    lzo_packages = get_lzo_packages(stack_version_unformatted)
  File "/Users/jhurley/src/apache/ambari/ambari-common/src/main/python/resource_management/libraries/functions/get_lzo_packages.py",
line 45, in get_lzo_packages
    lzo_packages += [script_instance.format_package_name("hadooplzo_${stack_version}"),
  File "/Users/jhurley/src/apache/ambari/ambari-common/src/main/python/resource_management/libraries/script/script.py",
line 520, in format_package_name
    stack_version_package_formatted = self.get_stack_version_before_packages_installed().replace('.',
package_delimiter).replace('-', package_delimiter) if STACK_VERSION_PLACEHOLDER in name else
name
  File "/Users/jhurley/src/apache/ambari/ambari-common/src/main/python/resource_management/libraries/script/script.py",
line 459, in get_stack_version_before_packages_installed
    stack_tools.get_stack_tool_package(stack_tools.STACK_SELECTOR_NAME))
  File "/Users/jhurley/src/apache/ambari/ambari-common/src/main/python/resource_management/libraries/functions/packages_analyzer.py",
line 319, in getInstalledPackageVersion
    code, out, err = rmf_shell.checked_call("rpm -q --queryformat '%{{version}}-%{{release}}'
{0} | sed -e 's/\.el[0-9]//g'".format(package_name), stderr=subprocess.PIPE)
ValueError: need more than 2 values to unpack

----------------------------------------------------------------------
Total run:1145
Total errors:18
Total failures:0
ERROR
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 01:30 min
[INFO] Finished at: 2017-08-09T13:29:14-04:00
[INFO] Final Memory: 21M/309M
[INFO] ------------------------------------------------------------------------
{code}

> Add hadoop LZO jars if installed in the cluster
> -----------------------------------------------
>
>                 Key: AMBARI-21642
>                 URL: https://issues.apache.org/jira/browse/AMBARI-21642
>             Project: Ambari
>          Issue Type: Improvement
>            Reporter: slim bouguerra
>            Assignee: slim bouguerra
>             Fix For: 2.6.0
>
>
> Check the existence of hadoop lzo packages and added to the druid-hadoop-clients directory.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message