ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antonenko Alexander (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-21601) Web Client Should Provide Repository ID For Upgrade Checks
Date Fri, 28 Jul 2017 14:38:00 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-21601?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Antonenko Alexander updated AMBARI-21601:
-----------------------------------------
    Attachment: AMBARI-21601.patch

> Web Client Should Provide Repository ID For Upgrade Checks
> ----------------------------------------------------------
>
>                 Key: AMBARI-21601
>                 URL: https://issues.apache.org/jira/browse/AMBARI-21601
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-web
>    Affects Versions: 2.5.3
>            Reporter: Antonenko Alexander
>            Assignee: Antonenko Alexander
>            Priority: Critical
>             Fix For: 2.5.3
>
>         Attachments: AMBARI-21601.patch
>
>
> Due to the changes in AMBARI-21552, the parameters passed into the pre-req checks for
upgrade have changed to include a repository ID. This is the target repository of the upgrade...
> The new query should look like:
> {code}
> GET api/v1/clusters/c1/rolling_upgrades_checkfields=*&
> UpgradeChecks/repository_version_id=2&
> UpgradeChecks/upgrade_type=ROLLING
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message