ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-21559) Alert definition paths should be updated on upgrade
Date Mon, 24 Jul 2017 13:11:01 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-21559?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16098345#comment-16098345
] 

Hadoop QA commented on AMBARI-21559:
------------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12878607/AMBARI-21559.patch
  against trunk revision .

    {color:red}-1 patch{color}.  The patch command could not apply the patch.

Console output: https://builds.apache.org/job/Ambari-trunk-test-patch/11844//console

This message is automatically generated.

> Alert definition paths should be updated on upgrade
> ---------------------------------------------------
>
>                 Key: AMBARI-21559
>                 URL: https://issues.apache.org/jira/browse/AMBARI-21559
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.5.2
>            Reporter: Doroszlai, Attila
>            Assignee: Doroszlai, Attila
>            Priority: Critical
>             Fix For: 2.5.2
>
>         Attachments: AMBARI-21559.patch
>
>
> Upon upgrading Ambari, alert scripts may be relocated in the new version.  Alert definitions
in the database should be updated to the new paths to avoid errors like:
> {noformat}
> Unable to execute alert. Unable to find 'AMBARI_METRICS/0.1.0.4.1/package/alerts/alert_ambari_metrics_monitor.py'
as an absolute path or part of /var/lib/ambari-agent/cache/stacks or /var/lib/ambari-agent/cache/host_scripts
> Unable to execute alert. Unable to find 'FLUME/1.6.0.4.2/package/alerts/alert_flume_agent_status.py'
as an absolute path or part of /var/lib/ambari-agent/cache/stacks or /var/lib/ambari-agent/cache/host_scripts
> Unable to execute alert. Unable to find 'HDFS/2.7.2.4.2/package/alerts/alert_checkpoint_time.py'
as an absolute path or part of /var/lib/ambari-agent/cache/stacks or /var/lib/ambari-agent/cache/host_scripts
> Unable to execute alert. Unable to find 'HDFS/2.7.2.4.2/package/alerts/alert_datanode_unmounted_data_dir.py'
as an absolute path or part of /var/lib/ambari-agent/cache/stacks or /var/lib/ambari-agent/cache/host_scripts
> Unable to execute alert. Unable to find 'HDFS/2.7.2.4.2/package/alerts/alert_ha_namenode_health.py'
as an absolute path or part of /var/lib/ambari-agent/cache/stacks or /var/lib/ambari-agent/cache/host_scripts
> Unable to execute alert. Unable to find 'HDFS/2.7.2.4.2/package/alerts/alert_upgrade_finalized.py'
as an absolute path or part of /var/lib/ambari-agent/cache/stacks or /var/lib/ambari-agent/cache/host_scripts
> Unable to execute alert. Unable to find 'YARN/2.7.2.4.2/package/alerts/alert_nodemanager_health.py'
as an absolute path or part of /var/lib/ambari-agent/cache/stacks or /var/lib/ambari-agent/cache/host_scripts
> Unable to execute alert. Unable to find 'YARN/2.7.2.4.2/package/alerts/alert_nodemanagers_summary.py'
as an absolute path or part of /var/lib/ambari-agent/cache/stacks or /var/lib/ambari-agent/cache/host_scripts
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message