ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Hurley (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-21522) Installation Commands On New Clusters Don't Send Down Correct Versions
Date Wed, 19 Jul 2017 20:33:01 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-21522?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jonathan Hurley updated AMBARI-21522:
-------------------------------------
    Attachment: AMBARI-21522.patch

> Installation Commands On New Clusters Don't Send Down Correct Versions
> ----------------------------------------------------------------------
>
>                 Key: AMBARI-21522
>                 URL: https://issues.apache.org/jira/browse/AMBARI-21522
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.5.2
>            Reporter: Jonathan Hurley
>            Assignee: Jonathan Hurley
>            Priority: Blocker
>             Fix For: 2.5.2
>
>         Attachments: AMBARI-21522.patch
>
>
> When installing a new cluster with Atlas, the cluster's version may not transition out
of {{INIT}}.
> This is being caused by Atlas Client - it's version is UNKNOWN.
> {code}
> ATLAS_CLIENT	UNKNOWN	6	INSTALLED	2	ATLAS
> HST_AGENT	UNKNOWN	6	STARTED	2	SMARTSENSE
> INFRA_SOLR_CLIENT	UNKNOWN	6	INSTALLED	2	AMBARI_INFRA
> LOGSEARCH_LOGFEEDER	UNKNOWN	6	STARTED	2	LOGSEARCH
> METRICS_COLLECTOR	UNKNOWN	6	STARTED	2	AMBARI_METRICS
> METRICS_GRAFANA	UNKNOWN	6	STARTED	2	AMBARI_METRICS
> METRICS_MONITOR	UNKNOWN	6	STARTED	2	AMBARI_METRICS
> {code}
> This is an HDP-2.6 cluster, which means that Atlas should be using 0.7.0.2.5:
> {code}
> ./src/main/resources/common-services/ATLAS/0.7.0.2.5/metainfo.xml:      <version>0.7.0.2.5</version>
> ./src/main/resources/stacks/HDP/2.5/services/ATLAS/metainfo.xml:      <version>0.7.0.2.5</version>
> ./src/main/resources/stacks/HDP/2.5/services/ATLAS/metainfo.xml:      <extends>common-services/ATLAS/0.7.0.2.5</extends>
> {code}
> In Atlas 0.7.0.2.5, it advertises a version:
> {code}
>         <component>
>           <name>ATLAS_CLIENT</name>
>           <cardinality>1+</cardinality>
>           <versionAdvertised>true</versionAdvertised>
>         </component>
>       </components>
> {code}
> The root cause is that the verison is not being sent in the {{commandParams}}:
> {code}
> 2017-07-19 15:43:49,739 - Stack Feature Version Info: Cluster Stack=2.6, Cluster Current
Version=None, Command Stack=None, Command Version=None-> 2.6
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message