ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hari Sekhon (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-21491) Ambari Metrics Collector gets dependency conflict on Suse 12 for snappy rpm vs libsnappy1 (@System)
Date Mon, 17 Jul 2017 13:11:00 GMT
Hari Sekhon created AMBARI-21491:
------------------------------------

             Summary: Ambari Metrics Collector gets dependency conflict on Suse 12 for snappy
rpm vs libsnappy1 (@System)
                 Key: AMBARI-21491
                 URL: https://issues.apache.org/jira/browse/AMBARI-21491
             Project: Ambari
          Issue Type: Bug
          Components: ambari-server
    Affects Versions: 2.5.1
         Environment: HDF 3.0 on Suse 12
            Reporter: Hari Sekhon


When installing HDF 3.0 via Ambari 2.5.1 the Ambari Metrics Collector fails to install due
to an rpm dependency conflict between the metrics collector rpm snappy and the system rpm
libsnappy1.

I've worked around this by finding the dependencies on the libsnappy1 rpm and removing them
like so:
{code}rpm -e yast2-kdump kdump crash makedumpfile libsnappy1{code}
and then retrying Ambari Metrics Collector install succeeds.

Ambari could probably apply this workaround automatically, or prompt the user to do so (perhaps
detect if libsnappy1 rpm is installed and pre-warn to do this in the first place).



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message