ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-21461) Spark thrift server restart fails during migration EU
Date Wed, 12 Jul 2017 23:31:00 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-21461?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16084904#comment-16084904
] 

Hadoop QA commented on AMBARI-21461:
------------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12876946/AMBARI-21461.patch
  against trunk revision .

    {color:red}-1 patch{color}.  The patch command could not apply the patch.

Console output: https://builds.apache.org/job/Ambari-trunk-test-patch/11780//console

This message is automatically generated.

> Spark thrift server restart fails during migration EU
> -----------------------------------------------------
>
>                 Key: AMBARI-21461
>                 URL: https://issues.apache.org/jira/browse/AMBARI-21461
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: branch-feature-AMBARI-21348
>            Reporter: Di Li
>            Assignee: Di Li
>             Fix For: branch-feature-AMBARI-21348
>
>         Attachments: AMBARI-21461.patch
>
>
> Spark in IOP 4.2 BigInsights stack uses script name "thrift_server.py" instead of "spark_thrift_server.py"
used by the common service Spark and the IOP 4.2.5 BigInsights stack.
> This seemed to have caused the following error during migration EU where Spark thrift
server failed to restart.
> """
> Caught an exception while executing custom service command: <class 'ambari_agent.AgentException.AgentException'>:
'Script /var/lib/ambari-agent/cache/common-services/SPARK/1.2.1/package/scripts/thrift_server.py
does not exist'; 'Script /var/lib/ambari-agent/cache/common-services/SPARK/1.2.1/package/scripts/thrift_server.py
does not exist'
> """
> We should be able to fix it by renaming "thrift_server.py" used in BI 4.2 stack to "spark_thrift_server.py"
and updating metainfo.xml files accordingly. 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message