ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-21434) UI - pass in param UpgradeChecks/target_stack to rolling_upgrade_checks endpoint
Date Tue, 11 Jul 2017 17:23:00 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-21434?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16082585#comment-16082585
] 

Hudson commented on AMBARI-21434:
---------------------------------

FAILURE: Integrated in Jenkins build Ambari-branch-2.5 #1667 (See [https://builds.apache.org/job/Ambari-branch-2.5/1667/])
AMBARI-21434 UI - pass in param UpgradeChecks/target_stack to (atkach: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=b3be727e178d3292e5619308973889be200a8588])
* (edit) ambari-web/app/controllers/main/admin/stack_and_upgrade_controller.js
* (edit) ambari-web/app/utils/ajax/ajax.js
* (edit) ambari-web/test/controllers/main/admin/stack_and_upgrade_controller_test.js


> UI - pass in param UpgradeChecks/target_stack to rolling_upgrade_checks endpoint
> --------------------------------------------------------------------------------
>
>                 Key: AMBARI-21434
>                 URL: https://issues.apache.org/jira/browse/AMBARI-21434
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-web
>    Affects Versions: 2.5.2
>            Reporter: Andrii Tkach
>            Assignee: Andrii Tkach
>            Priority: Blocker
>             Fix For: 2.5.2
>
>         Attachments: AMBARI-21434.patch
>
>
> See AMBARI-21411
> The backend now needs an extra parameter when invoking the RU/EU PreChecks.
> E.g.,
> {noformat}
> curl -u admin:admin -H "X-Requested-By: ambari" -i -X GET 'http://localhost:8080/api/v1/clusters/c1/rolling_upgrades_check?fields=*&UpgradeChecks/repository_version=2.6.1.0-129&UpgradeChecks/upgrade_type=NON_ROLLING&UpgradeChecks/target_stack=HDP-2.6'
> {noformat}
> This new param is now required
> {noformat}
> UpgradeChecks/target_stack=<value>
> {noformat}
> in order to correctly run the PreChecks.
> This needs to go into the feature branch, which will later be merged into 2.5-maint



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message