ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alejandro Fernandez (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-21411) Backend - Run EU/RU PreChecks during a cross-stack upgrade
Date Thu, 06 Jul 2017 00:19:01 GMT
Alejandro Fernandez created AMBARI-21411:
--------------------------------------------

             Summary: Backend - Run EU/RU PreChecks during a cross-stack upgrade
                 Key: AMBARI-21411
                 URL: https://issues.apache.org/jira/browse/AMBARI-21411
             Project: Ambari
          Issue Type: Bug
          Components: ambari-server
    Affects Versions: 2.5.2
            Reporter: Alejandro Fernandez
            Assignee: Alejandro Fernandez
             Fix For: 2.5.2


During a cross-stack upgrade, the PreChecks need to be able to run.

STR:
* Install BigInsights 4.2.5
* Upgrade Ambari to 2.5
* Register bits for HDP 2.6
* Install bits for HDP 2.6
* Attempt to run PreChecks

{noformat}
curl -u admin:admin -H "X-Requested-By: ambari" -i -X GET http://localhost:8080/api/v1/clusters/c1/rolling_upgrades_check?fields=*&UpgradeChecks/repository_version=2.6.1.0-129&UpgradeChecks/upgrade_type=NON_ROLLING&UpgradeChecks/upgrade_pack=nonrolling-upgrade-to-hdp-2.6
{noformat}

This returns,
{noformat}
{
  "status" : 500,
  "message" : "org.apache.ambari.server.controller.spi.SystemException: Repository version
null was not found"
}
{noformat}

because in UpgradeHelper.java it cannot find the upgrade pack.

The new API will requiring passing in a new argument, e.g., UpgradeChecks/target_stack=HDP-2.6



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message