ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Onischuk (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-21379) Ambari Agent doesn't start as non-root user with "ambari-agent start" logged in as root
Date Fri, 30 Jun 2017 08:24:00 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-21379?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andrew Onischuk updated AMBARI-21379:
-------------------------------------
    Attachment: AMBARI-21379.patch

> Ambari Agent doesn't start as non-root user with "ambari-agent start" logged in as root
> ---------------------------------------------------------------------------------------
>
>                 Key: AMBARI-21379
>                 URL: https://issues.apache.org/jira/browse/AMBARI-21379
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Andrew Onischuk
>            Assignee: Andrew Onischuk
>             Fix For: 2.5.2
>
>         Attachments: AMBARI-21379.patch
>
>
> When running Ambari Server and Agents as non-root user, If I logged in as
> root, then agent process doesn't start with user mentioned in run_as from
> ambari-agent.ini when I run "$ambari-agent start" whereas running "$service
> ambari-agent start" launches the agent process with run_as user.
> Ambari Server doesn't show this behaviour when logged in as root and running
> commands "$ambari-server start" or "$service ambari-server start" always start
> with non-root user.
> Locally tested with Ambari 2.4.2.0 version



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message