ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doroszlai, Attila (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-21195) Enforce minimum Maven version
Date Thu, 08 Jun 2017 09:12:18 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-21195?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Doroszlai, Attila updated AMBARI-21195:
---------------------------------------
    Resolution: Fixed
        Status: Resolved  (was: Patch Available)

Committed to [trunk|http://git-wip-us.apache.org/repos/asf/ambari/commit/9b44b62f].

> Enforce minimum Maven version
> -----------------------------
>
>                 Key: AMBARI-21195
>                 URL: https://issues.apache.org/jira/browse/AMBARI-21195
>             Project: Ambari
>          Issue Type: Improvement
>          Components: ambari-server
>    Affects Versions: 3.0.0
>            Reporter: Doroszlai, Attila
>            Assignee: Doroszlai, Attila
>            Priority: Minor
>             Fix For: 3.0.0
>
>         Attachments: AMBARI-21195.patch
>
>
> Ambari build may fail with the following cryptic error due to using old Maven:
> {noformat}
> [ERROR] Failed to execute goal com.github.kongchen:swagger-maven-plugin:3.1.4:generate
(default) on project ambari-server: Unable to parse configuration of mojo com.github.kongchen:swagger-maven-plugin:3.1.4:generate
for parameter locations: Cannot assign configuration entry 'locations' with value 'org.apache.ambari.server.api.services'
of type java.lang.String to property of type java.util.List -> [Help 1]
> {noformat}
> It turns out that swagger-maven-plugin needs Maven 3.3.9+.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message