ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-21149) Configurations Created During Upgrade Must Use Correct StackId Based on Service
Date Wed, 31 May 2017 21:48:04 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-21149?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16032046#comment-16032046
] 

Hudson commented on AMBARI-21149:
---------------------------------

FAILURE: Integrated in Jenkins build Ambari-trunk-Commit #7555 (See [https://builds.apache.org/job/Ambari-trunk-Commit/7555/])
AMBARI-21149 - Configurations Created During Upgrade Must Use Correct (jhurley: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=2892aee53e63077c422c4c68dd565e786d83a71d])
* (edit) ambari-server/src/main/java/org/apache/ambari/server/serveraction/upgrades/ConfigureAction.java
* (edit) ambari-server/src/main/java/org/apache/ambari/server/upgrade/UpgradeCatalog200.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/serveraction/kerberos/UpdateKerberosConfigsServerActionTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/upgrade/UpgradeCatalog200Test.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/state/UpgradeHelperTest.java
* (edit) ambari-server/src/main/java/org/apache/ambari/server/serveraction/kerberos/UpdateKerberosConfigsServerAction.java
* (edit) ambari-server/src/main/java/org/apache/ambari/server/state/UpgradeHelper.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/upgrade/UpgradeCatalog240Test.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/serveraction/upgrades/ConfigureActionTest.java
* (edit) ambari-server/src/main/java/org/apache/ambari/server/controller/KerberosHelperImpl.java
* (edit) ambari-server/src/main/java/org/apache/ambari/server/state/ConfigHelper.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/serveraction/upgrades/UpgradeActionTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/state/ConfigHelperTest.java
* (edit) ambari-server/src/main/java/org/apache/ambari/server/upgrade/UpgradeCatalog240.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/controller/internal/StackUpgradeConfigurationMergeTest.java
* (edit) ambari-server/src/main/java/org/apache/ambari/server/state/stack/upgrade/ClusterGrouping.java


> Configurations Created During Upgrade Must Use Correct StackId Based on Service
> -------------------------------------------------------------------------------
>
>                 Key: AMBARI-21149
>                 URL: https://issues.apache.org/jira/browse/AMBARI-21149
>             Project: Ambari
>          Issue Type: Task
>          Components: ambari-server
>    Affects Versions: trunk
>            Reporter: Jonathan Hurley
>            Assignee: Jonathan Hurley
>            Priority: Critical
>             Fix For: trunk
>
>         Attachments: AMBARI-21149.patch
>
>
> When creating an upgrade, the configurations which are part of {{ConfigureAction}} are
still using the cluster's "current" version when creating new configs. This needs to be changed
to using the source/target versions of the service in the upgrade.
> {code}
> ambari=# select config_id, type_name version_tag, stack_id, selected from clusterconfig
order by type_name, config_id, version_tag;                                              
                                                                                         
                                                                config_id |            version_tag
            | stack_id | selected
> -----------+------------------------------------+----------+----------
>          5 | cluster-env                        |       13 |        0
>          9 | cluster-env                        |       13 |        0
>         18 | cluster-env                        |       13 |        0
>         56 | cluster-env                        |       12 |        0
>        102 | cluster-env                        |       13 |        0
>        107 | cluster-env                        |       12 |        0
>        113 | cluster-env                        |       13 |        0
>        118 | cluster-env                        |       12 |        0
>        152 | cluster-env                        |       13 |        0
>        157 | cluster-env                        |       12 |        1
>         10 | ranger-storm-audit                 |       13 |        0
>        162 | ranger-storm-audit                 |       12 |        1
>         11 | ranger-storm-plugin-properties     |       13 |        0
>        155 | ranger-storm-plugin-properties     |       12 |        1
>         12 | ranger-storm-policymgr-ssl         |       13 |        0
>        158 | ranger-storm-policymgr-ssl         |       12 |        1
>         13 | ranger-storm-security              |       13 |        0
>        161 | ranger-storm-security              |       12 |        1
>         19 | storm-atlas-application.properties |       13 |        0
>        156 | storm-atlas-application.properties |       12 |        1
>         14 | storm-cluster-log4j                |       13 |        0
>        160 | storm-cluster-log4j                |       13 |        1
>         15 | storm-env                          |       13 |        0
>        153 | storm-env                          |       12 |        1
>         16 | storm-site                         |       13 |        0
>        154 | storm-site                         |       12 |        1
>         17 | storm-worker-log4j                 |       13 |        0
>        159 | storm-worker-log4j                 |       13 |        1
>          2 | zoo.cfg                            |       13 |        0
>          6 | zoo.cfg                            |       13 |        1
>          4 | zookeeper-env                      |       13 |        0
>          8 | zookeeper-env                      |       13 |        1
>          3 | zookeeper-log4j                    |       13 |        0
>          7 | zookeeper-log4j                    |       13 |        1
> (34 rows)
> {code}
> The {{storm-cluster-log4j}} and {{storm-worker-log4j}} are selected with the wrong stack
ID ... they need to be on 12 (HDP 2.6) not 13 (HDP 2.5).



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message