ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sangeeta Ravindran (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-21120) Roles below Cluster Administrator should not be allowed to edit repositories and install stack versions
Date Thu, 25 May 2017 21:01:04 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-21120?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sangeeta Ravindran updated AMBARI-21120:
----------------------------------------
    Attachment: AMBARI-21120.patch

> Roles below Cluster Administrator should not be allowed to edit repositories and install
stack versions
> -------------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-21120
>                 URL: https://issues.apache.org/jira/browse/AMBARI-21120
>             Project: Ambari
>          Issue Type: Bug
>    Affects Versions: trunk
>            Reporter: Sangeeta Ravindran
>            Assignee: Sangeeta Ravindran
>            Priority: Minor
>             Fix For: trunk
>
>         Attachments: AMBARI-21120.patch
>
>
> Login as a user with a role below Cluster Administrator. For e.g. Service Admnistrator.
> Click on Stack and Versions.
> 1. Try to edit a stack version that is not yet installed on the cluster.
> Click on Save. The UI reloads and returns to Services Dashboard.
> On the browser console, you can see a HTTP 403 because the user does not have the privilege
to edit stack versions. 
> 2. Click on Install. When you click on on the popup confirming that the packages will
be installed on all hosts, you get a popup with an error "Packages could not be installed.
You do not have permissions to access this resource".
>  



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message