ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-21102) To/From Version Information is Incorrect When Looking at Prior Upgrades
Date Wed, 31 May 2017 21:48:04 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-21102?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16032045#comment-16032045
] 

Hudson commented on AMBARI-21102:
---------------------------------

FAILURE: Integrated in Jenkins build Ambari-trunk-Commit #7555 (See [https://builds.apache.org/job/Ambari-trunk-Commit/7555/])
AMBARI-21102. To/From Version Information is Incorrect When Looking at (hiveww: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=7a7f489bc51a0351f9e2c0c1fbb79180319f1d80])
* (edit) ambari-web/app/views/main/admin/stack_upgrade/upgrade_history_view.js
* (edit) ambari-web/app/utils/array_utils.js
* (edit) ambari-web/test/views/main/admin/stack_upgrade/upgrade_history_view_test.js
* (edit) ambari-web/app/models/stack_version/stack_upgrade_history.js
* (edit) ambari-web/app/templates/main/admin/stack_upgrade/upgrade_history.hbs


> To/From Version Information is Incorrect When Looking at Prior Upgrades
> -----------------------------------------------------------------------
>
>                 Key: AMBARI-21102
>                 URL: https://issues.apache.org/jira/browse/AMBARI-21102
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-web
>    Affects Versions: 3.0.0
>            Reporter: Antonenko Alexander
>            Assignee: Antonenko Alexander
>             Fix For: 3.0.0
>
>         Attachments: AMBARI-21102.patch, Screen Shot 2017-05-19 at 2.50.50 PM.png, Screen
Shot 2017-05-19 at 2.51.04 PM.png
>
>
> Create a SERVICE or PATCH upgrade for a single service. Once the upgrade completes, the
"Upgrade History" section of Ambari contains incorrect information:
> - The upgrade says "Upgrade from 2.5.4.0", yet 2.5.4.0 was the target. It should say
"Upgrade to 2.5.4.0". When dowgrading, it should use the "from" preposition.
> - The To/From fields are still present in the list of upgrades, and they are blank. They
should be removed and a per-service display should be used instead.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message