ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sumit Mohanty (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-21081) Upgrade to 2.5.1 from 2.5.0 adds cgroups related configs back to YARN and indicates restart required
Date Sat, 20 May 2017 05:59:04 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-21081?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sumit Mohanty updated AMBARI-21081:
-----------------------------------
    Attachment: AMBARI-21081.patch

> Upgrade to 2.5.1 from 2.5.0 adds cgroups related configs back to YARN and indicates restart
required
> ----------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-21081
>                 URL: https://issues.apache.org/jira/browse/AMBARI-21081
>             Project: Ambari
>          Issue Type: Bug
>          Components: stacks
>    Affects Versions: 2.5.1
>            Reporter: Sumit Mohanty
>            Assignee: Sumit Mohanty
>            Priority: Critical
>             Fix For: 2.5.2
>
>         Attachments: AMBARI-21081.patch, Screen Shot 2017-05-19 at 10.42.46 PM.png
>
>
> Upgrading to 2.5.1 after a fresh install of HDP-2.6 using 2.5.0.3, adds cgroup configs
and results in YARN restart required indicator.
>  
>  !Screen Shot 2017-05-19 at 10.42.46 PM.png|thumbnail! 
> This is because https://issues.apache.org/jira/browse/AMBARI-19311 added the logic to
remove these configs when cgroup is not enabled but as the config properties have {{<on-ambari-upgrade
add="true"/>}} they get auto added when Ambari is upgraded.
> I believe simply setting {{<on-ambari-upgrade add="true"/>}} to {{<on-ambari-upgrade
add="false"/>}} will fix this issue.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message