ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Madhuvanthi Radhakrishnan (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-20974) Ambari fails to start due to NPE after installation of HDF mpack
Date Tue, 09 May 2017 20:23:04 GMT
Madhuvanthi Radhakrishnan created AMBARI-20974:
--------------------------------------------------

             Summary: Ambari fails to start due to NPE after installation of HDF mpack
                 Key: AMBARI-20974
                 URL: https://issues.apache.org/jira/browse/AMBARI-20974
             Project: Ambari
          Issue Type: Bug
          Components: ambari-sever
            Reporter: Madhuvanthi Radhakrishnan
            Assignee: Madhuvanthi Radhakrishnan
             Fix For: 2.5.1


when we install HDF mpack we do the following steps
yum install ambari-server
ambari-server install-mpack --mpack=/path/to/hdf-mpack --purge --verbose
ambari-server setup
The permissions and ownership for stacks , common-services etc is set correctly during ambari-server
setup
Ambari-server daemon is configured to run under user 'slava'. Change this setting [y/n] (n)?
n
Adjusting ambari-server permissions and ownership...
However, to add HDF services to HDP cluster we install the mpack after deploying the HDP cluster
and hence when running Ambari as non-root and with umask = 0027, the permissions and ownerships
don't get updated.
Workaround:
Re-run ambari-server setup command after installing the HDF mpack but don't really make any
config changes. Run this step only to update the permissions.
 ambari-server setup -s



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message