ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "JaySenSharma (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-20943) Hive View 1.5 and 2.0 result with special characters are being printed as ?
Date Fri, 05 May 2017 15:47:04 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-20943?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

JaySenSharma updated AMBARI-20943:
----------------------------------
    Attachment: Issue1.png

> Hive View 1.5 and 2.0 result with special characters are being printed as ?
> ---------------------------------------------------------------------------
>
>                 Key: AMBARI-20943
>                 URL: https://issues.apache.org/jira/browse/AMBARI-20943
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-views
>    Affects Versions: 2.5.0
>         Environment: All
>            Reporter: JaySenSharma
>         Attachments: Issue1.png
>
>
> - Hive View result panel is not showing special character data properly. The special
characters are being replaced with ?
> Example: Run the following queries from Hive View 1.5/2.0 in Ambari 2.5 and then check
the result section.
> {code}
> CREATE TABLE IF NOT EXISTS customerinfo (address string) ROW FORMAT SERDE 'org.apache.hadoop.hive.serde2.lazy.LazySimpleSerDe'
WITH SERDEPROPERTIES("serialization.encoding"='UTF-8','store.charset'='UTF-8', 'retrieve.charset'='UTF-8');
> INSERT INTO customerinfo VALUES ("Envägen");
> SELECT * FROM customerinfo;
> {code}
> - Result is printed as following:
> {code}
> Env�gen
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message