ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yusaku Sako (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-20926) Ranger Quick links not showing load balancer in Ranger-admin HA
Date Fri, 05 May 2017 17:21:04 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-20926?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15998606#comment-15998606
] 

Yusaku Sako commented on AMBARI-20926:
--------------------------------------

Committed to branch-2.4.

> Ranger Quick links not showing load balancer in Ranger-admin HA
> ---------------------------------------------------------------
>
>                 Key: AMBARI-20926
>                 URL: https://issues.apache.org/jira/browse/AMBARI-20926
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-web
>    Affects Versions: 2.5.0, 2.4.2
>            Reporter: Xi Wang
>            Assignee: Xi Wang
>             Fix For: 2.5.1, 2.4.3
>
>         Attachments: AMBARI-20926-branch-2.4.patch, AMBARI-20926-branch-2.5.patch, AMBARI-20926-trunk.patch
>
>
> Ranger Quick links not pointing to load balancer URL when ranger HA is enabled. Quick
links pointing to http://<ranger_admin_host>:6080 port.
> Ambari affected: 2.4.2 and 2.5.0.3
> Prior to ambari upgrade in 2.2.2, quicklink was showing only the Ranger loadbalancer
UI. After upgrading to 2.4.2, it showing both ranger admin URLs instead of the load balancer
URL in quicklinks. 
> Solution: 
> Should always use Ranger External URL property for the quick link. (admin-properties.xml/policymgr_external_url)



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message