ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-20835) Unable to proceed from manual prompt in EU wizard due to IllegalArgumentException
Date Mon, 24 Apr 2017 22:24:04 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-20835?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15982014#comment-15982014
] 

Hudson commented on AMBARI-20835:
---------------------------------

SUCCESS: Integrated in Jenkins build Ambari-branch-2.5 #1442 (See [https://builds.apache.org/job/Ambari-branch-2.5/1442/])
AMBARI-20835. Unable to proceed from manual prompt in EU wizard due to (ncole: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=883779d2209c7de7cec7190d91f380c517dc83f7])
* (edit) ambari-server/src/main/java/org/apache/ambari/server/state/cluster/ClustersImpl.java
* (edit) ambari-server/src/main/java/org/apache/ambari/server/serveraction/upgrades/FixCapacitySchedulerOrderingPolicy.java
* (edit) ambari-server/src/main/java/org/apache/ambari/server/actionmanager/ActionDBAccessorImpl.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/controller/AmbariManagementControllerTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/actionmanager/TestActionManager.java
* (edit) ambari-server/src/main/java/org/apache/ambari/server/orm/dao/HostRoleCommandDAO.java


> Unable to proceed from manual prompt in EU wizard due to IllegalArgumentException
> ---------------------------------------------------------------------------------
>
>                 Key: AMBARI-20835
>                 URL: https://issues.apache.org/jira/browse/AMBARI-20835
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-sever
>    Affects Versions: 2.5.1
>            Reporter: Vivek Sharma
>            Assignee: Nate Cole
>            Priority: Blocker
>              Labels: express_upgrade
>             Fix For: 2.5.1
>
>         Attachments: AMBARI-20835.patch
>
>
> *STR*
> # Deployed cluster with Ambari version: 2.2.2.0 and HDP version: 2.4.2.0-258
> # Upgrade Ambari to target Version: 2.5.1.0-42 | Hash: ac1f26f309bf23d684089baa6d3db9fa96b92ecc
> # Register HDP-2.6.1.0-22 version and install the bits
> # Start Express Upgrade and hit Proceed at first manual prompt to 'Stop slider apps'
> *Result*
> Request fails:
> {code}
> {
>   "status" : 400,
>   "message" : "java.lang.IllegalArgumentException: Can not transition a stage from COMPLETED
to COMPLETED"
> }
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message