ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-20799) Ambari fails to upgrade from 2.4.2.0 to 2.5.1.0 during schema upgrade with NPE
Date Thu, 20 Apr 2017 15:24:04 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-20799?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15976893#comment-15976893
] 

Hadoop QA commented on AMBARI-20799:
------------------------------------

{color:green}+1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12864262/AMBARI-20799.patch
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:green}+1 tests included{color}.  The patch appears to include 1 new or modified
test files.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 core tests{color}.  The patch passed unit tests in ambari-server.

Test results: https://builds.apache.org/job/Ambari-trunk-test-patch/11427//testReport/
Console output: https://builds.apache.org/job/Ambari-trunk-test-patch/11427//console

This message is automatically generated.

> Ambari fails to upgrade from 2.4.2.0 to 2.5.1.0 during schema upgrade with NPE
> ------------------------------------------------------------------------------
>
>                 Key: AMBARI-20799
>                 URL: https://issues.apache.org/jira/browse/AMBARI-20799
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.5.1
>            Reporter: Mahesh Nayak
>            Assignee: Jonathan Hurley
>             Fix For: 2.5.1
>
>         Attachments: AMBARI-20799.patch
>
>
> On trying to upgrade ambari from 2.4.2.0 to 2.5.1.0 upgrade is failing with nullPointerException
during ambari schema upgrade
> {code:None}
> 20 Apr 2017 05:55:01,410 ERROR [main] SchemaUpgradeHelper:257 - Upgrade failed.
> java.lang.NullPointerException
>         at org.apache.ambari.server.upgrade.AbstractUpgradeCatalog.updateMetaInfoVersion(AbstractUpgradeCatalog.java:272)
>         at org.apache.ambari.server.orm.AmbariJpaLocalTxnInterceptor.invoke(AmbariJpaLocalTxnInterceptor.java:128)
>         at org.apache.ambari.server.upgrade.AbstractUpgradeCatalog.updateDatabaseSchemaVersion(AbstractUpgradeCatalog.java:949)
>         at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.executeOnPostUpgrade(SchemaUpgradeHelper.java:255)
>         at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.main(SchemaUpgradeHelper.java:433)
> 20 Apr 2017 05:55:01,413 ERROR [main] SchemaUpgradeHelper:444 - Exception occurred during
upgrade, failed
> org.apache.ambari.server.AmbariException
>         at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.executeOnPostUpgrade(SchemaUpgradeHelper.java:258)
>         at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.main(SchemaUpgradeHelper.java:433)
> Caused by: java.lang.NullPointerException
>         at org.apache.ambari.server.upgrade.AbstractUpgradeCatalog.updateMetaInfoVersion(AbstractUpgradeCatalog.java:272)
>         at org.apache.ambari.server.orm.AmbariJpaLocalTxnInterceptor.invoke(AmbariJpaLocalTxnInterceptor.java:128)
>         at org.apache.ambari.server.upgrade.AbstractUpgradeCatalog.updateDatabaseSchemaVersion(AbstractUpgradeCatalog.java:949)
>         at org.apache.ambari.server.upgrade.SchemaUpgradeHelper.executeOnPostUpgrade(SchemaUpgradeHelper.java:255)
>         ... 1 more
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message