ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-20726) Aggregate alert does not show status properly after Maintenance Mode change
Date Wed, 12 Apr 2017 20:31:41 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-20726?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15966564#comment-15966564
] 

Hadoop QA commented on AMBARI-20726:
------------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12863112/AMBARI-20726.patch
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:green}+1 tests included{color}.  The patch appears to include 1 new or modified
test files.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:red}-1 core tests{color}.  The test build failed in ambari-server 

Test results: https://builds.apache.org/job/Ambari-trunk-test-patch/11375//testReport/
Console output: https://builds.apache.org/job/Ambari-trunk-test-patch/11375//console

This message is automatically generated.

> Aggregate alert does not show status properly after Maintenance Mode change
> ---------------------------------------------------------------------------
>
>                 Key: AMBARI-20726
>                 URL: https://issues.apache.org/jira/browse/AMBARI-20726
>             Project: Ambari
>          Issue Type: Bug
>          Components: alerts
>    Affects Versions: 2.4.2
>            Reporter: Qin Liu
>            Assignee: Qin Liu
>            Priority: Minor
>             Fix For: trunk
>
>         Attachments: AMBARI-20726.patch
>
>
> Aggregate alert does not show status properly after Maintenance Mode change.
> Steps to reproduce:
> install a cluster that has HBase with 1 regionserver installed
> Scenario 1
> 1. Turn On Maintenance Mode on one RegionServer or on the RegionServer host or on HBase
service
> 2. Stop the RegionServer after that
> 3. No red alerts came as expected.
> Percent RegionServers Available - OK affected: [0], total: [1]
> 4. Now Turned Off Maintenance Mode, still kept the Region Server down.
> But Percent RegionServers Available alert still showing "OK"
> Scenario 2:
> 1) Stopped one RegionServer - Red alert seen as expected
> Percent RegionServers Available - CRIT affected: [1], total: [1] 
> 2) Now Turned On Maintenance Mode - For RegionServer status, Red alert gone as expected
> But Percent RegionServers Available alert showing "CRIT"



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message