ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alejandro Fernandez (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-20511) YARN Service Check failing due to incorrect jar name, Slider failing due to storm plugin conf not present at the moment
Date Mon, 20 Mar 2017 21:45:42 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-20511?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Alejandro Fernandez updated AMBARI-20511:
-----------------------------------------
    Status: Patch Available  (was: Open)

> YARN Service Check failing due to incorrect jar name, Slider failing due to storm plugin
conf not present at the moment
> -----------------------------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-20511
>                 URL: https://issues.apache.org/jira/browse/AMBARI-20511
>             Project: Ambari
>          Issue Type: Bug
>          Components: stacks
>    Affects Versions: 3.0.0
>            Reporter: Alejandro Fernandez
>            Assignee: Alejandro Fernandez
>             Fix For: 3.0.0
>
>         Attachments: AMBARI-20511.patch
>
>
> YARN service check is failing on HDP 3.0 since Ambari is still looking for a 2.* jar
instead of 3.*
> {noformat}
> Traceback (most recent call last):
>   File "/var/lib/ambari-agent/cache/common-services/YARN/3.0.0.3.0/package/scripts/mapred_service_check.py",
line 172, in <module>
>     MapReduce2ServiceCheck().execute()
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 314, in execute
>     method(env)
>   File "/var/lib/ambari-agent/cache/common-services/YARN/3.0.0.3.0/package/scripts/mapred_service_check.py",
line 158, in service_check
>     logoutput=True)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 155,
in __init__
>     self.env.run()
>   File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line
160, in run
>     self.run_action(resource, action)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line
124, in run_action
>     provider_action()
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/providers/execute_hadoop.py",
line 44, in action_run
>     environment = self.resource.environment,
>   File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 155,
in __init__
>     self.env.run()
>   File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line
160, in run
>     self.run_action(resource, action)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line
124, in run_action
>     provider_action()
>   File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py",
line 262, in action_run
>     tries=self.resource.tries, try_sleep=self.resource.try_sleep)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 72,
in inner
>     result = function(command, **kwargs)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 102,
in checked_call
>     tries=tries, try_sleep=try_sleep, timeout_kill_strategy=timeout_kill_strategy)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 150,
in _call_wrapper
>     result = _call(command, **kwargs_copy)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/shell.py", line 303,
in _call
>     raise ExecutionFailed(err_msg, code, out, err)
> resource_management.core.exceptions.ExecutionFailed: Execution of 'hadoop --config /usr/hdp/current/hadoop-client/conf
jar /usr/hdp/current/hadoop-mapreduce-client/hadoop-mapreduce-examples-2.*.jar wordcount /user/ambari-qa/mapredsmokeinput
/user/ambari-qa/mapredsmokeoutput' returned 255. JAR does not exist or is not a normal file:
/usr/hdp/3.0.0.0-154/hadoop-mapreduce/hadoop-mapreduce-examples-2.*.jar
> {noformat}
> Slider is failing because it currently does not have the Storm plugin, which is expected
this early in the release, so comment it out for now.
> {noformat}
> Traceback (most recent call last):
>   File "/usr/lib/python2.6/site-packages/resource_management/core/sudo.py", line 72,
in makedirs
>     os.makedirs(path, mode)
>   File "/usr/lib64/python2.6/os.py", line 157, in makedirs
>     mkdir(name, mode)
> OSError: [Errno 2] No such file or directory: '/usr/hdp/current/storm-slider-client/conf'
> The above exception was the cause of the following exception:
> Traceback (most recent call last):
>   File "/var/lib/ambari-agent/cache/common-services/SLIDER/0.91.0.3.0/package/scripts/slider_client.py",
line 71, in <module>
>     SliderClient().execute()
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 314, in execute
>     method(env)
>   File "/var/lib/ambari-agent/cache/common-services/SLIDER/0.91.0.3.0/package/scripts/slider_client.py",
line 55, in install
>     self.configure(env)
>   File "/usr/lib/python2.6/site-packages/resource_management/libraries/script/script.py",
line 117, in locking_configure
>     original_configure(obj, *args, **kw)
>   File "/var/lib/ambari-agent/cache/common-services/SLIDER/0.91.0.3.0/package/scripts/slider_client.py",
line 60, in configure
>     slider()
>   File "/usr/lib/python2.6/site-packages/ambari_commons/os_family_impl.py", line 89,
in thunk
>     return fn(*args, **kwargs)
>   File "/var/lib/ambari-agent/cache/common-services/SLIDER/0.91.0.3.0/package/scripts/slider.py",
line 75, in slider
>     create_parents = True
>   File "/usr/lib/python2.6/site-packages/resource_management/core/base.py", line 155,
in __init__
>     self.env.run()
>   File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line
160, in run
>     self.run_action(resource, action)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/environment.py", line
124, in run_action
>     provider_action()
>   File "/usr/lib/python2.6/site-packages/resource_management/core/providers/system.py",
line 185, in action_create
>     sudo.makedirs(path, self.resource.mode or 0755)
>   File "/usr/lib/python2.6/site-packages/resource_management/core/sudo.py", line 77,
in makedirs
>     raise Fail("Cannot create directory '{0}' as '{1}' is a broken symlink".format(path,
dirname))
> resource_management.core.exceptions.Fail: Cannot create directory '/usr/hdp/current/storm-slider-client/conf'
as '/usr/hdp/current/storm-slider-client' is a broken symlink
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message