ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alejandro Fernandez (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-20490) Fixes for Express Upgrade on large-scale clusters: batch execute-stage for hdp-select set all, EU from HDP 2.2 to 2.5
Date Fri, 24 Mar 2017 19:33:41 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-20490?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Alejandro Fernandez updated AMBARI-20490:
-----------------------------------------
    Summary: Fixes for Express Upgrade on large-scale clusters: batch execute-stage for hdp-select
set all, EU from HDP 2.2 to 2.5  (was: Fixes for Express Upgrade on large-scale clusters:
batch execute-stage for hdp-select set all, alert for hdp-select versions, EU from HDP 2.2
to 2.5)

> Fixes for Express Upgrade on large-scale clusters: batch execute-stage for hdp-select
set all, EU from HDP 2.2 to 2.5
> ---------------------------------------------------------------------------------------------------------------------
>
>                 Key: AMBARI-20490
>                 URL: https://issues.apache.org/jira/browse/AMBARI-20490
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.4.0
>            Reporter: Alejandro Fernandez
>            Assignee: Alejandro Fernandez
>             Fix For: trunk
>
>         Attachments: AMBARI-20490.branch-2.4.patch, AMBARI-20490.branch-2.5.patch, AMBARI-20490.trunk.patch
>
>
> On large-scale clusters over 1000 nodes, performance during Express Upgrade can be very
slow and it takes more time to fix potential errors.
> We can remedy these with the following fixes:
> * "hdp-select set all" is currently ran in the ClusterGroup with a single stage instead
of batching. This can cause Ambari Server to be the bottleneck when processing 1000+ requests.
Allow the execute-stage inside a ClusterGroup to use batching.
> * If some hosts have symlinks or dirs that don't belong in /usr/hdp/ then it will prevent
the hosts from running "hdp-select versions". We can find these problematic hosts with an
alert.
> * There is currently no upgrade path from HDP 2.2 directly to 2.5. Doing a 2-step upgrade
is very time consuming (only for branch 2.4 since HDP 2.2 no longer supported in Ambari 2.5).



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message