ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "JaySenSharma (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-18961) Ambari HiveView does not create or upload script in UTF-8 format
Date Sun, 26 Mar 2017 13:50:41 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-18961?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

JaySenSharma updated AMBARI-18961:
----------------------------------
    Attachment:     (was: AMBARI-18961.patch)

> Ambari HiveView does not create or upload script in UTF-8 format
> ----------------------------------------------------------------
>
>                 Key: AMBARI-18961
>                 URL: https://issues.apache.org/jira/browse/AMBARI-18961
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-views
>    Affects Versions: 2.4.1
>         Environment: All
>            Reporter: JaySenSharma
>            Assignee: JaySenSharma
>         Attachments: Result.png
>
>
> - When we run an insert query with some special character in the Hive (Hive-next) View
then we see that the values are not being reflected properly.  The special characters are
being replaced with  "?"
> Example:
> {code}
> CREATE table test (id int, name string);
> insert into test values (100, "€");
> insert into test values (200, "$");
> insert into test values (300, "£");
> insert into test values (400, "₡");
> SELECT * FROM test LIMIT 100;
> {code}
> - Once the above script is executed then we will see the output something like "HiveView_UTF-8_Issue.png"
(attached)



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message