ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-20212) Remove HDP version check in KAFKA service
Date Mon, 27 Feb 2017 20:21:46 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-20212?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15886468#comment-15886468
] 

Hudson commented on AMBARI-20212:
---------------------------------

SUCCESS: Integrated in Jenkins build Ambari-branch-2.5 #1114 (See [https://builds.apache.org/job/Ambari-branch-2.5/1114/])
AMBARI-20212. Remove HDP version check in KAFKA service (Madhuvanthi (smohanty: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=7e28c6b30668d013fdccaa7d3827a3726e940f01])
* (edit) ambari-server/src/main/resources/common-services/KAFKA/0.8.1/package/scripts/kafka_broker.py
* (edit) ambari-server/src/main/resources/stacks/HDP/2.0.6/properties/stack_features.json


> Remove HDP version check in KAFKA service
> -----------------------------------------
>
>                 Key: AMBARI-20212
>                 URL: https://issues.apache.org/jira/browse/AMBARI-20212
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>            Reporter: Madhuvanthi Radhakrishnan
>            Assignee: Madhuvanthi Radhakrishnan
>             Fix For: 2.5.0
>
>         Attachments: AMBARI-20212.patch, AMBARI-20212_trunk.patch
>
>
> Need to fix following code in KAFKA.
> {code}
>       if compare_versions(src_version, '2.3.4.0') < 0 and compare_versions(dst_version,
'2.3.4.0') >= 0:
>         # Calling the acl migration script requires the configs to be present.
>         self.configure(env, upgrade_type=upgrade_type)
>         upgrade.run_migration(env, upgrade_type)
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message