ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Levas (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AMBARI-20196) Ambari should install the unlimited key JCE policy based on service requirements even if cluster is not Kerberized
Date Sat, 25 Feb 2017 22:12:44 GMT
Robert Levas created AMBARI-20196:
-------------------------------------

             Summary: Ambari should install the unlimited key JCE policy based on service
requirements even if cluster is not Kerberized
                 Key: AMBARI-20196
                 URL: https://issues.apache.org/jira/browse/AMBARI-20196
             Project: Ambari
          Issue Type: Bug
          Components: ambari-agent, ambari-server
    Affects Versions: 2.4.0
            Reporter: Robert Levas
            Assignee: Robert Levas
             Fix For: 2.5.0


Ambari should install the unlimited key JCE policy based on service requirements even if cluster
is not Kerberized.  For example, if a service needs the unlimited key JCE policy for an encryption
task not related to Kerberos.

On a similar note, the unlimited key JCE policy is not being distributed to the agents if
Kerberos is enabled using the "manual" option - as opposed to integrating with an existing
KDC. 

On a related note, Ambari Server host automatically unpacks JCE unlimited during "ambari-server
setup" (unless custom JDK is used).




--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message