ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Hurley (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-20120) Error during EU while updating Ranger Log4J service configs
Date Thu, 23 Feb 2017 13:52:44 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-20120?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jonathan Hurley updated AMBARI-20120:
-------------------------------------
    Resolution: Fixed
        Status: Resolved  (was: Patch Available)

> Error during EU while updating Ranger Log4J service configs
> -----------------------------------------------------------
>
>                 Key: AMBARI-20120
>                 URL: https://issues.apache.org/jira/browse/AMBARI-20120
>             Project: Ambari
>          Issue Type: Bug
>    Affects Versions: 2.5.0
>            Reporter: Jonathan Hurley
>            Assignee: Jonathan Hurley
>            Priority: Critical
>             Fix For: 2.5.0
>
>         Attachments: AMBARI-20120.patch
>
>
> Perform an HDP upgrade from 2.3 to 2.4 where Ranger is an installed service.
> *Result*
> Observed errors while updating below Ranger service configs:
> Updating configuration usersync-log4j
> Updating configuration admin-log4j
> {code}
> Server action failed
> Could not find desired config type with name admin-log4j
> {code}
> - Both {{usersync-log4j}} and {{admin-log4j}} appear in Ranger 0.6.0 which is first used
by HDP 2.5. Therefore, the configuration changes should simply be removed from upgrades on
stacks before HDP 2.5
> - Additionally, I found {{RANGER_TAGSYNC}} references in HDP 2.3 and HDP 2.4. This component
also first appeared in Ranger 0.6.0, so it should also be removed from earlier upgrade packs.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message