ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-19797) ambari-server SuSE11 init script not working in certain environments
Date Thu, 23 Feb 2017 12:25:44 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-19797?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15880333#comment-15880333
] 

Hudson commented on AMBARI-19797:
---------------------------------

SUCCESS: Integrated in Jenkins build Ambari-trunk-Commit #6826 (See [https://builds.apache.org/job/Ambari-trunk-Commit/6826/])
AMBARI-19797. ambari-server SuSE11 init script not working in certain (aonishuk: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=aeb5d4e550cecd7ee93aa968669c5e54ae2226dc])
* (edit) ambari-agent/etc/init.d/ambari-agent
* (edit) ambari-server/sbin/ambari-server


> ambari-server SuSE11 init script not working in certain environments
> --------------------------------------------------------------------
>
>                 Key: AMBARI-19797
>                 URL: https://issues.apache.org/jira/browse/AMBARI-19797
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Andrew Onischuk
>            Assignee: Andrew Onischuk
>             Fix For: 2.5.0
>
>         Attachments: AMBARI-19797.patch
>
>
> On SuSE11, the same sysvinit script as used for RHEL6 is being installed.  
> On RHEL6, this contains the chkconfig header specifying that ambari-server and
> ambari-agent services should start as late as possible:  
> head -2 /etc/init.d/ambari-server  
> #!/usr/bin/env bash  
> chkconfig: 345 95 20  
> head -2 /etc/init.d/ambari-agent  
> #!/usr/bin/env bash  
> chkconfig: 345 95 20  
> However, these instructions are not honored by Suse, leading to the init
> scrips being scheduled as the first ones to start, before networking and other
> essentials:  
> ls -l /etc/init.d/rc3.d/|grep ambari  
> lrwxrwxrwx 1 root root 15 Jan 23 20:57 K01ambari-agent -> ../ambari-agent  
> lrwxrwxrwx 1 root root 16 Jan 23 20:57 K01ambari-server -> ../ambari-server  
> lrwxrwxrwx 1 root root 15 Jan 23 20:09 S01ambari-agent -> ../ambari-agent  
> lrwxrwxrwx 1 root root 16 Jan 23 20:57 S01ambari-server -> ../ambari-server  
> The ambari-server fails to automatically start after reboot on an Suse11
> system due to the service starting before the network (with the following
> error, also attached in the logs):  
> 1) Error injecting constructor, java.net.UnknownHostException:
> ip-172-31-23-241: ip-172-31-23-241: unknown error  
> This especially happens on system where DNS is being used for resolve
> hostnames (such as on AWS or many users).  
> STR:
> Install a SuSE11 SP4, preferably on AWS or remove any references from
> /etc/hosts.  
> Install the Ambari repo, the packages and run the setup:  
> wget -nv <http://public-
> repo-1.hortonworks.com/ambari/suse11/2.x/updates/2.4.2.0/ambari.repo> -O
> /etc/zypp/repos.d/ambari.repo  
> zypper -n install ambari-agent ambari-server  
> ambari-server setup  
> /etc/init.d/ambari-server start  
> reboot  
> Notice the ambari-server does not come up after reboot.  
> How to fix:  
> As per <https://www.novell.com/support/kb/doc.php?id=7002295>, the solution is
> to set # Required-Start: $ALL in the script headers.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message