ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-19740) Ambari upgrade to Ambari 2.5 causes start DB check failure on Zeppelin configs
Date Wed, 01 Feb 2017 10:11:52 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-19740?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15848199#comment-15848199
] 

Hudson commented on AMBARI-19740:
---------------------------------

FAILURE: Integrated in Jenkins build Ambari-branch-2.5 #862 (See [https://builds.apache.org/job/Ambari-branch-2.5/862/])
AMBARI-19740 Ambari upgrade to Ambari 2.5 causes start DB check failure (renjith.kamath: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=dc0257f8f554dff0d13ef5cdbae29891625cc365])
* (edit) ambari-server/src/main/java/org/apache/ambari/server/upgrade/UpgradeCatalog250.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/upgrade/UpgradeCatalog250Test.java


> Ambari upgrade to Ambari 2.5 causes start DB check failure on Zeppelin configs
> ------------------------------------------------------------------------------
>
>                 Key: AMBARI-19740
>                 URL: https://issues.apache.org/jira/browse/AMBARI-19740
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Renjith Kamath
>            Assignee: Renjith Kamath
>             Fix For: 2.5.0
>
>         Attachments: AMBARI-19740-branch-2.5-v1.patch
>
>
> Ambari upgrade to Ambari 2.5 causes start DB check failure on Zeppelin configs:
> {noformat}
> 017-01-11 15:50:16,078  INFO - Comparing required service configs from stack with mapped
service configs from db
> 2017-01-11 15:50:16,084 ERROR - Required config(s): zeppelin-log4j-properties,zeppelin-shiro-ini
is(are) not available for service ZEPPELIN with service config version 3 in cluster c1
> 2017-01-11 15:50:16,084  INFO - Getting services which has mapped configs which are not
selected in clusterconfigmapping
> {noformat}
> HDP version 2.5 was not upgraded. 
> *Steps to reproduce*
> # Install Ambari 2.4.2
> # Create cluster using HDP 2.5 - including Zeppelin
> # Enable Kerberos (probably not necessary)
> # Upgrade Ambari to 2.5.0
> # Attempt to start Ambari
> # See error message in {{/var/log/ambari-server/ambari-server-check-database.log}}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message