ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Miklos Gergely (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-19723) Log Search portal not working if only solr needs SSL connection
Date Thu, 26 Jan 2017 10:38:25 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-19723?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Miklos Gergely updated AMBARI-19723:
------------------------------------
    Attachment: AMBARI-19723.patch

> Log Search portal not working if only solr needs SSL connection
> ---------------------------------------------------------------
>
>                 Key: AMBARI-19723
>                 URL: https://issues.apache.org/jira/browse/AMBARI-19723
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-logsearch
>    Affects Versions: 2.5.0
>            Reporter: Miklos Gergely
>            Assignee: Miklos Gergely
>            Priority: Critical
>             Fix For: 2.5.0
>
>         Attachments: AMBARI-19723.patch
>
>
> If Log Search portal uses SSL only for solr (no https protocol is set for the portal,
or to communicate with ambari) then it's not working, as nothing enforces the keystore / truststore
passwords to load. Loading these passwords should not be enforced only by loading the SSLContext,
it should be done if there is a keystrore / truststore location specified - i.e. the portal
uses SSL.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message