ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nate Cole (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-19596) ZKFC version shows incorrect in DB tables upon downgrade
Date Tue, 17 Jan 2017 19:20:26 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-19596?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Nate Cole updated AMBARI-19596:
-------------------------------
    Attachment: AMBARI-19596.patch

> ZKFC version shows incorrect in DB tables upon downgrade
> --------------------------------------------------------
>
>                 Key: AMBARI-19596
>                 URL: https://issues.apache.org/jira/browse/AMBARI-19596
>             Project: Ambari
>          Issue Type: Bug
>            Reporter: Nate Cole
>            Assignee: Nate Cole
>            Priority: Critical
>             Fix For: 2.5.0
>
>         Attachments: AMBARI-19596.patch
>
>
> Steps:
> * Install ZKFC using HDP-2.3.
> * Register a version for HDP-2.6
> * Start Upgrade
> * At first chance, start Downgrade
> in HDP-2.6, ZKFC is marked as {{versionAdvertised=false}}.  In HDP-2.6, {{versionAdvertised=true}}.
 On downgrade, that compnent's desired version should be marked UNKNOWN with upgrade state
of NONE.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message