ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-19365) Executing ambari-server unit tests with JDK 1.8 results in unit test failures
Date Thu, 05 Jan 2017 23:08:58 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-19365?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15802813#comment-15802813
] 

Hudson commented on AMBARI-19365:
---------------------------------

FAILURE: Integrated in Jenkins build Ambari-trunk-Commit #6369 (See [https://builds.apache.org/job/Ambari-trunk-Commit/6369/])
Revert "AMBARI-19365. Executing ambari-server unit tests with JDK 1.8 (rlevas: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=9109d1c3b9c20c98310472c05b1572d744c58363])
* (edit) ambari-server/src/main/java/org/apache/ambari/server/controller/utilities/KerberosChecker.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/controller/utilities/KerberosCheckerTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/metric/system/impl/JvmMetricsSourceTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/security/authentication/AmbariBasicAuthenticationFilterTest.java
* (delete) ambari-server/src/main/java/org/apache/ambari/server/controller/utilities/LoginContextHelper.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/view/persistence/DataStoreImplTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/upgrade/UpgradeCatalog222Test.java
AMBARI-19365. Executing ambari-server unit tests with JDK 1.8 results in (rlevas: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=bd1b744403bfa9c6e6aaf02e7c56062e7fdb21cd])
* (add) ambari-server/src/main/java/org/apache/ambari/server/controller/utilities/LoginContextHelper.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/upgrade/UpgradeCatalog222Test.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/metric/system/impl/JvmMetricsSourceTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/controller/utilities/KerberosCheckerTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/view/persistence/DataStoreImplTest.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/security/authentication/AmbariBasicAuthenticationFilterTest.java
* (edit) ambari-server/src/main/java/org/apache/ambari/server/controller/utilities/KerberosChecker.java


> Executing ambari-server unit tests with JDK 1.8 results in unit test failures
> -----------------------------------------------------------------------------
>
>                 Key: AMBARI-19365
>                 URL: https://issues.apache.org/jira/browse/AMBARI-19365
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.5.0
>            Reporter: Robert Levas
>            Assignee: Robert Levas
>            Priority: Critical
>              Labels: jdk1_8, unit-test
>             Fix For: 2.5.0
>
>         Attachments: AMBARI-19365_branch-2.5_01.patch, AMBARI-19365_trunk_01.patch
>
>
> Following unit tests fails when executed with JDK 1.8
> {code}
> mvn test -Dtest=DataStoreImplTest
> mvn clean test -Dtest=UpgradeCatalog222Test
> mvn test -Dtest=KerberosCheckerTest,AmbariBasicAuthenticationFilterTest
> {code}
> Same unit tests passes if the environment is switched to use JDK 1.7



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message