ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Levas (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-19365) Executing ambari-server unit tests with JDK 1.8 results in unit test failures
Date Thu, 05 Jan 2017 01:44:58 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-19365?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Levas updated AMBARI-19365:
----------------------------------
    Attachment: AMBARI-19365_trunk_01.patch
                AMBARI-19365_branch-2.5_01.patch

> Executing ambari-server unit tests with JDK 1.8 results in unit test failures
> -----------------------------------------------------------------------------
>
>                 Key: AMBARI-19365
>                 URL: https://issues.apache.org/jira/browse/AMBARI-19365
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.5.0
>            Reporter: Robert Levas
>            Assignee: Robert Levas
>            Priority: Critical
>              Labels: jdk1_8, unit-test
>             Fix For: 2.5.0
>
>         Attachments: AMBARI-19365_branch-2.5_01.patch, AMBARI-19365_trunk_01.patch
>
>
> Following unit tests fails when executed with JDK 1.8
> {code}
> mvn test -Dtest=DataStoreImplTest
> mvn clean test -Dtest=UpgradeCatalog222Test
> mvn test -Dtest=KerberosCheckerTest,AmbariBasicAuthenticationFilterTest
> {code}
> Same unit tests passes if the environment is switched to use JDK 1.7



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message