ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Hurley (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMBARI-19073) Ambari Contrib View Has Inconsistent Version in pom.xml
Date Sat, 03 Dec 2016 02:19:58 GMT

     [ https://issues.apache.org/jira/browse/AMBARI-19073?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jonathan Hurley updated AMBARI-19073:
-------------------------------------
    Description: 
{{contrib/views/ambari-views-package/pom.xml}} has the wrong version defined which can cause
build failures under certain conditions. The parent POM from {{contrib/views/pom.xml}} defines
2.0.0.0.0 while {{contrib/views/ambari-views-package/pom.xml}} defines 2.5.0.0.0.

{code}
git diff pom.xml
diff --git a/contrib/views/ambari-views-package/pom.xml b/contrib/views/ambari-views-package/pom.xml
index cb070e6..16c9985 100644
--- a/contrib/views/ambari-views-package/pom.xml
+++ b/contrib/views/ambari-views-package/pom.xml
@@ -26,7 +26,7 @@
   <parent>
     <groupId>org.apache.ambari.contrib.views</groupId>
     <artifactId>ambari-contrib-views</artifactId>
-    <version>2.5.0.0.0</version>
+    <version>2.0.0.0-SNAPSHOT</version>
   </parent>
{code}

This now matches {{contrib/views/pom.xml}}:}
{code}
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
         xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
  <parent>
    <groupId>org.apache.ambari</groupId>
    <artifactId>ambari-project</artifactId>
    <version>2.0.0.0-SNAPSHOT</version>
    <relativePath>../../ambari-project</relativePath>
  </parent>
{code}

> Ambari Contrib View Has Inconsistent Version in pom.xml
> -------------------------------------------------------
>
>                 Key: AMBARI-19073
>                 URL: https://issues.apache.org/jira/browse/AMBARI-19073
>             Project: Ambari
>          Issue Type: Bug
>          Components: contrib
>    Affects Versions: trunk
>            Reporter: Jonathan Hurley
>            Priority: Critical
>             Fix For: trunk
>
>
> {{contrib/views/ambari-views-package/pom.xml}} has the wrong version defined which can
cause build failures under certain conditions. The parent POM from {{contrib/views/pom.xml}}
defines 2.0.0.0.0 while {{contrib/views/ambari-views-package/pom.xml}} defines 2.5.0.0.0.
> {code}
> git diff pom.xml
> diff --git a/contrib/views/ambari-views-package/pom.xml b/contrib/views/ambari-views-package/pom.xml
> index cb070e6..16c9985 100644
> --- a/contrib/views/ambari-views-package/pom.xml
> +++ b/contrib/views/ambari-views-package/pom.xml
> @@ -26,7 +26,7 @@
>    <parent>
>      <groupId>org.apache.ambari.contrib.views</groupId>
>      <artifactId>ambari-contrib-views</artifactId>
> -    <version>2.5.0.0.0</version>
> +    <version>2.0.0.0-SNAPSHOT</version>
>    </parent>
> {code}
> This now matches {{contrib/views/pom.xml}}:}
> {code}
> <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
>          xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
>   <parent>
>     <groupId>org.apache.ambari</groupId>
>     <artifactId>ambari-project</artifactId>
>     <version>2.0.0.0-SNAPSHOT</version>
>     <relativePath>../../ambari-project</relativePath>
>   </parent>
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message