ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jaimin Jetly (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-18932) "Add Service Wizard in Progress" keeps showing to other admin users even after restart
Date Thu, 22 Dec 2016 02:20:58 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-18932?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15768787#comment-15768787
] 

Jaimin Jetly commented on AMBARI-18932:
---------------------------------------

[~JaySenSharma]
This is expected behavior added as part of AMBARI-13123. Other users are not expected to do
any service operations when wizard is in progress or else it can potentially hamper the wizard.

If for some reason any admin user have not started any wizard but still they are seeing this
label then the workaround given by you can be done. Further  resolution of AMBARI-19276 will
allow to do this workaround from ui itself.

I am closing this one as "works as designed". 
Feel free to reopen if you know that ambari shows that label even when none of the admin user
has ongoing running wizard

> "Add Service Wizard in Progress" keeps showing to other admin users even after restart
> --------------------------------------------------------------------------------------
>
>                 Key: AMBARI-18932
>                 URL: https://issues.apache.org/jira/browse/AMBARI-18932
>             Project: Ambari
>          Issue Type: Bug
>          Components: ambari-server
>    Affects Versions: 2.4.1
>         Environment: All
>            Reporter: JaySenSharma
>
> - If there are more than one Ambari Admin users present.  Then if one of the admin user
 say "admin1"   click on the "Actions" => "Add Service"  in the ambari UI  and does nothing.
Then other logged in admin users will keep seeing the "Add Service Wizard in Progress" blinking
bar in the ambari UI and the "service action"  dropdown button will not be visible to them.
> *Issue*
> *#######*
> - If some other admin user will click on the the "Add Service" wizard but did not close
it. So other logged in users will see the blinking message " Add Service Wizard in Progress"
and will not be able to see any "Service Actions" dropdown.
> Steps to reproduce the issue is as following:
> *Step-1).* Run the following Curl command:
> {code}
> curl -u admin:admin -i -H 'X-Requested-By: ambari' -X POST -d '{"wizard-data":"{\"userName\":\"admin\",\"controllerName\":\"addServiceController\"}"}'
http://standaloneambari.example.com:8080/api/v1/persist
> {code}
> *Step-2).* Login to the Ambari UI with "admin" user.
> *Step-3).* Create a new "local" user with some name like "admin1" (any password like
"admin1")
> *Step-4).* Open *another* browser and login with the "admin1" user. User might see that
the "Add Service Wizard in Progress" link is blinking at the top.
> *Step-5).* Now from the earlier browser where we logged in with "admin" user. We will
need to click on the "Actions" => "Add Service"
> *Step-6).* Now if the "admin" user does nothing. Or Shuts down his/her laptop.  Still
the other admin users (like "admin1") will not be able to perform any action in the ambari
UI  and will keep seeing the "Add Service Wizard in Progress" link is blinking at the top.
> *NOTE:* Even restarting the ambari server will not resolved the issue for other admin
users.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message