ambari-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMBARI-18699) Upgrade Configuration Packs Should Have an XSD
Date Wed, 26 Oct 2016 20:12:59 GMT

    [ https://issues.apache.org/jira/browse/AMBARI-18699?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15609535#comment-15609535
] 

Hudson commented on AMBARI-18699:
---------------------------------

FAILURE: Integrated in Jenkins build Ambari-branch-2.5 #209 (See [https://builds.apache.org/job/Ambari-branch-2.5/209/])
AMBARI-18699 - Upgrade Configuration Packs Should Have an XSD (jhurley: [http://git-wip-us.apache.org/repos/asf?p=ambari.git&a=commit&h=d69eb017a21948c87fe72c8e7c0f96f0358ae94e])
* (edit) ambari-server/src/test/resources/stacks_with_upgrade_cycle/HDP/2.2.0/upgrades/config-upgrade.xml
* (edit) ambari-server/src/test/resources/stacks/HDP/2.2.0/upgrades/config-upgrade.xml
* (edit) ambari-server/src/test/java/org/apache/ambari/server/state/UpgradeHelperTest.java
* (edit) ambari-server/src/main/resources/stacks/HDP/2.5/upgrades/config-upgrade.xml
* (edit) ambari-server/src/main/resources/stacks/HDP/2.3/upgrades/config-upgrade.xml
* (edit) ambari-server/src/main/resources/stacks/HDP/2.2/upgrades/config-upgrade.xml
* (edit) ambari-server/src/test/resources/stacks/HDP/2.1.1/upgrades/config-upgrade.xml
* (edit) ambari-server/src/main/java/org/apache/ambari/server/state/stack/upgrade/ConfigureTask.java
* (edit) ambari-server/src/test/resources/stacks/HDP/2.1.1/upgrades/upgrade_test.xml
* (edit) ambari-server/src/main/java/org/apache/ambari/server/state/stack/upgrade/ConfigUpgradeChangeDefinition.java
* (edit) ambari-server/src/test/java/org/apache/ambari/server/state/stack/ConfigUpgradeValidityTest.java
* (edit) ambari-server/src/main/resources/stacks/HDP/2.4/upgrades/config-upgrade.xml
* (add) ambari-server/src/main/resources/upgrade-config.xsd


> Upgrade Configuration Packs Should Have an XSD
> ----------------------------------------------
>
>                 Key: AMBARI-18699
>                 URL: https://issues.apache.org/jira/browse/AMBARI-18699
>             Project: Ambari
>          Issue Type: Task
>    Affects Versions: 2.5.0
>            Reporter: Jonathan Hurley
>            Assignee: Jonathan Hurley
>            Priority: Critical
>             Fix For: 2.5.0
>
>         Attachments: AMBARI-18699.patch
>
>
> The {{config-upgrade.xml}} packs which define the configuration changes during an upgrade
do not have an XSD to validate them. They also contain and outdated and deprecated element
called {{condition}} which can be replaced.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message